New Idea

Scheduled Reports are taking error "Before the data import for (Data Source Name) finished, its data source timed out."  Most reports have 60 min. timeout coded and error occurs after a couple minutes.  Start of last week, a couple reports showed error.  By Fend of week about half the scheduled reports took the error.  Administrator restarted/rebooted Enterprise Gateway.  Reports immediately ran fine.  This week, a similar pattern emerged.  Some reports fail at start of week and by Friday, high percentage of reports failed with this error message.  Data sources are accessing SQL Server & Oracle databases.  We know the restart of the Gateway is the quick fix, but seems like there is a bigger issue.

Datasets that include a query that merges data coming from a web data source on one side and another set of data coming from an on-Premises data source can't be refreshed using the On-Premises data gateway.

Error messages depend on the kind of the web data source. For example:

  • Sharepoint Online List: "The credentials provided for the SharePoint source are invalid"
  • Excel in Sharepoint Online (Web Connector): "SharePoint: Request failed: https://[...]"

I tried to merge data

  • from On-Prem Oracle with SPO List
  • from On-Prem Excel with SPO List
  • from On-Prem Excel with Excel in Sharepoint Online (Web Connector)

Every attempt failed. Tested with On-Prem Data Gateway 12-2018. I followed this documentation. According to this announcement this should work.

 

However, refreshes succeed when I access the identical data sources with reports that do NOT merge the data in a query:
Merge Test Result.png

 

PowerBI workspaces are not loading

Status: Delivered
by holgerdeubel Visitor on ‎01-15-2019 06:15 AM
At the moment, we can login to PowerBI.com, but it's very slowly and the Workspaces are not loading. After a while the following error message appears
 
Etwas ist schief gelaufen.
Versuchen Sie es später noch einmal.
TECHNISCHE DETAILS 
Unbekannter Fehler. Wenn dieser Fehler auch weiterhin auftritt, geben Sie bitte die folgenden Informationen an, wenn Sie sich an den Support wenden.
Datum und Uhrzeit: : 2019-01-15 13:57:17Z
ActivityId: 0f7366e9-91c5-413b-ae70-b491a2b42817
 
The meaning is: Somthing went wrong, please try again later. Unknown error.
 
All collegues are hit by this error, no one can work with powerbi online. 
 
Regards
Holger
Status: Delivered

All Refreshes fail without indicating reason

Status: Accepted
by sabinek Occasional Visitor on ‎12-10-2018 12:59 AM

Hello everyone,

 

I have setup four datasets with schedueled refreshes (each once a day on different times). The first few days they all work well and all of a sudden they fail without any reason:

image.png

 

Manual refreshes in the power BI portal succeed (sometimes also the schedueld refresh the next day) but then the refreshes fail again

I had a MS consultant looking at it but his advices (recreate the DB connection and reconfigure the refreshes) did not resolve the problems on a long term.

 

Here also some of the most important information about the circumstances:

Is the data source in Azure or on premises with gateway?
It is an Azure SQL database for three data sets (alwas the same db) and once an application insigts of an azure web app.
Is the problem only with one data source?
No, besides the 3 error messages for datasets based on this Azure SQL DB, the same error message occurred in parallel for a data source based on Applications Insights.
Has the problem occurred several days in a row or by chance?
The first time and also now the initial error message occurs randomly. The error repeats itself with every refresh until the Scheduled Refresh is disabled by the system. When I reactivate it, it works for some days (a week?) and then fails again.
Does the problem always occur on certain days?
As mentioned above, on each refresh, once the error occurred.
If you then restart the refresh manually, does it work?
The manual refresh works and sometimes the scheduled refresh works the next day, but then it fails again.
Here you can see the history of one dataset:
image.png
One more hint: It doesn't seem to depend on the number of refresh runs, but on the duration:
I restarted the Scheduled Refreshs for all 4 datasets on 29.11. One refresh ran twice a day and all others only once. All 4 datasets started to throw error messages on the 4.12.
 
If there is anyone who can help with that problem, I would be very glad.
 
Thanks in advance!
Status: Accepted

Privacy setting for a data source in the data gateway is reset to "None" whenever I cancel a process of setting up a dataflow entity with the data source and the gateway. I have not been successful in setting up a connection with any data sources at this time, so I do not know what would happen if I DON'T cancel the process. I am able to recreate the condition every time. This appears to be a bug, but I would like a confirmation that I am not doing something wrong to cause this.

Scheduled Refresh Fail

Status: New
by irishboy79 Frequent Visitor on ‎12-17-2018 02:35 AM

Multiple Scheulded refreshes are failing daliy and for multiple reports. The number of reports failing is increasing. I have updated to latest version of the gateway on Dec 13th but it doesnt appear to have improved matters. Refresh Now works successfully.

 

An example of error in notification email is:

 

Technical Information

Activity Id: 4311c979-72e0-4f47-9835-2cfb3cf987f1

Request Id: 06dcdf07-4bd4-4890-b1dd-347138e40f4e

Cluster Name: WABI-NORTH-EUROPE-redirect.analysis.windows.net

Refresh Start Time: December 17, 2018 10:01 UTC

Refresh End Time: December 17, 2018 10:02 UTC

 

Any ideas what is causing this or what the fix may be?

 

Regards

Cian

I try to get my table from my dataset in Bigquery into Power BI Desktop. But unfortnately I m getting to follwing error:

 

DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job first-projec:job_dm6z7i391YiYbOwjL7t-ydZ4V26dd6dfnv8
Details:
DataSourceKind=GoogleBigQuery
DataSourcePath=GoogleBigQuery
OdbcErrors=Table

 

I tried the following to lose this error:

- Changing this line in the M source code:

Quelle = GoogleBigQuery.Database(null)

to:

Quelle = GoogleBigQuery.Database([BillingProject="Billing-Project-Id"]) 

- I used the Simba ODBC driver as described here : Simba-BigQuery-ODBC-Driver-Quickstart2.pdf

 

Is this still a bug in Power BI?

 

P.S: my dataset and google cloud storage are in the same region, europ-west2

 

 

Fix the "Data Loading" / "Almost Done" issue

Status: New
by SMHolck Frequent Visitor on ‎10-02-2018 02:56 PM

Multiple people in my organization are unable to view published apps in our Power BI tenant.  They can sometimes click Apps and then wait for it to load forever.  You see a brief message "Data Loading" followed by "Almost Done."  And it will spin for hours.  My entire company has a Pro license.  The data loads fine in my Power BI desktop.  Issue happens on both IE 11 and Chrome 69.   Good thing I'm not currently doing my presentation on why you should use Azure!AlmostDone.png

 

I've seen this happen often and on.  You never know when it is going to happen.  My Azure admin says when he logs in to Azure portal it tells him no known outages.

 

 

broken gateway installer

Status: Accepted
by pisarz Occasional Visitor on ‎09-26-2018 02:31 AM

I try to install on premise gateway on new windows 10 pro , i run installer  downloaded from powerbi.microsoft.com and get errors:

 yellow window with missing certificate for this exe and then window with error: Application pop-up GatewayInstall.exe - Application Error : The application was unable to start correctly (0xc0000005). Click OK to close the application.

 

this error doesnt even shows on windows 10 , there is only event in EventViewer->System. It shows only if I run installer in win8 compatiblity mode.

 

I could attach screens but don't know to this here

Status: Accepted

Cancellation occurred when sending or receiving a request.

Status: New
by hugo6262 Visitor ‎01-11-2018 08:09 AM - edited ‎01-11-2018 08:11 AM

Hello, Im unable to refresh one of my reports, the gateway is ok, and in power BI destkop refreshes properly. can you help me out, I get this message:

Last refresh failed: Thu Jan 11 2018 16:29:15 GMT+0100 (Romance Standard Time) 
Cancellation occurred when sending or receiving a request

Cluster URI:WABI-EUROPE-NORTH-B-redirect.analysis.windows.net
Activity ID:c21669ce-c606-4dc0-93d6-66fc6578519d
Request ID:3a01ab7b-abe3-e1d6-dbf1-2fc09cde3c1c
Time:2018-01-11 15:29:15Z

 

Yesterday, all my datasets were refreshing just fine but today nothing happens.

- The automatic refresh hasn't done anything.

- When I press "Refresh now", I get a "popup" saying "preparing refresh" for a split second and then nothing happens.

 

The only way to update the data is to refresh the Desktop version and then upload it. 

 

I have datasets connection to an on-premises database and one connecting to a sharepoint site.

- The on-premises connection usually works perfect, but now nothing happens.

- The sharepoint connection usually brings up an error,  if I try to refresh, but now nothing happens (I just tried it this time as a test, as it usually doesn't work automatically).

 

Can you please help troublefinding - It seems like an issue on you online portal somehow.

 

Thanks in advance.

 

// Tommy

Status: Delivered

Unable to Install Power BI Gateway

Status: Accepted
by vikrammankar Frequent Visitor on ‎09-24-2018 03:39 AM

Hi,

 

I am unable to install Power BI Gateway Installer.

 

My Machine Specifications:
             OS: 64 Bit OS

             Installed memory (RAM): 8GB

             Processor: i5-6300U CPU @ 2.40GHz

             Office Version: 2010 (32 Bit)

             Power BI (32 Bit)

 

Mentioned below is the message I am getting.

 

"PowerBIGatewayInstaller has stopped working.

A problem caused the program to stop working correctly.  Please close the program."

 

Request your extended support in resolving the same.

 

Thanks & Regards

Vikram.

Status: Accepted

 

Capture.PNG

 

Getting the above error when trying to refresh my report using the fuzzy merge preview feature (New with October release.) Have updated On-premises data gateway to October's release. Refreshes fine on desktop. Any ideas?

Bug Power BI Gateway installation error/crash

Status: Accepted
by TM Frequent Visitor on ‎09-20-2017 01:55 AM

I am having issues installing the Power BI Gateway (powerbigatewayinstaller.exe). It seems the installer doesn't initiate/run.

I think there might be an issue with the application itself, since I am having the same issues on three different computers.

 

I have tried: 

  • Run as administrator
  • Start the installer from Run
  • Check the Task Manager if the process is actually running, with no trace of the gateway.

So I figured I check the Event viewer, and found a .net runtime error with event id 1026. There's also an application error, but I presume this is down to the .net runtime error. The information from the event viewer is as follows:

 

Tillämpningsprogram: PowerBIGatewayInstaller.exe
Framework-version: v4.0.30319
Beskrivning: Processen avslutades på grund av ett ohanterat undantag.
Undantagsinformation: System.IO.FileNotFoundException
   vid Microsoft.DataProxy.PowerBIInstallDownloader.LandingPageViewModel..ctor(Microsoft.DataProxy.PowerBIInstallDownloader.MainViewModel)
   vid Microsoft.DataProxy.PowerBIInstallDownloader.MainViewModel..ctor()
   vid Microsoft.DataProxy.PowerBIInstallDownloader.MainWindow..ctor()

Undantagsinformation: System.Windows.Markup.XamlParseException
   vid System.Windows.Markup.XamlReader.RewrapException(System.Exception, System.Xaml.IXamlLineInfo, System.Uri)
   vid System.Windows.Markup.WpfXamlLoader.Load(System.Xaml.XamlReader, System.Xaml.IXamlObjectWriterFactory, Boolean, System.Object, System.Xaml.XamlObjectWriterSettings, System.Uri)
   vid System.Windows.Markup.WpfXamlLoader.LoadBaml(System.Xaml.XamlReader, Boolean, System.Object, System.Xaml.Permissions.XamlAccessLevel, System.Uri)
   vid System.Windows.Markup.XamlReader.LoadBaml(System.IO.Stream, System.Windows.Markup.ParserContext, System.Object, Boolean)
   vid System.Windows.Application.LoadBamlStreamWithSyncInfo(System.IO.Stream, System.Windows.Markup.ParserContext)
   vid System.Windows.Application.DoStartup()
   vid System.Windows.Application.<.ctor>b__1_0(System.Object)
   vid System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
   vid System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
   vid System.Windows.Threading.DispatcherOperation.InvokeImpl()
   vid System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   vid System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   vid System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   vid MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)
   vid System.Windows.Threading.DispatcherOperation.Invoke()
   vid System.Windows.Threading.Dispatcher.ProcessQueue()
   vid System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
   vid MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
   vid MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
   vid System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
   vid System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
   vid System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
   vid MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
   vid MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
   vid System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
   vid System.Windows.Application.RunDispatcher(System.Object)
   vid System.Windows.Application.RunInternal(System.Windows.Window)
   vid Microsoft.DataProxy.PowerBIInstallDownloader.App.Main()

 

Status: Accepted

Invalid Credentials on Scheduled Refresh

Status: Accepted
by paulopaim Frequent Visitor on ‎11-21-2016 05:05 AM

I'm having the problem below, I've put the credentials again, but the error continues.

 

powerbierror.PNG

Status: Accepted

AWS hosted Postgres -- Connectivity Issues

Status: Needs Info
by jc03701 Visitor on ‎08-07-2018 12:20 PM

Having trouble with intermitten connectivity to a postgres instance hosted by AWS.  It is similar to the outage experienced last week that was temporarily resolved. Can connect occasionally but not consistently.  Causing a huge pain for my organization.

Status: Needs Info

Hi

I'm Experiencing translation problems in PowerBI when uploading my Tabular model from SSAS v. 10.0.1.439 (compatability level 1400)

 

I have downloaded the latest On-premises data gateway version number: 14.16.6650.1 and it works fine. 

 

In app.powerbi.com I have changed the settings to the same local language as have been made in the tabular model, but it doesn't translate the table names and table columns. 

 

It does however translate the folders and the measures. Is there a setting that I'm missing. On other sql setups, there is no problem with the translation it works fine, however it is not SSAS 2017 and it is with an older version of the on-premises data gateway.

 

 

 

Status: Needs Info

errorJPG.JPG

I'm getting this error since yesterday on a new dataset. It is a simple excel file table. I've done the following.

Signed out of Power BI Desktop and back in

Got the latest personal gateway

turned the gateway service off / on

republished multiple times during this process.

 

Others seem to be having the same issue. see thread here

There is a current support site error message, but it is specific to SharePoint as a data source only.

Status: Accepted

 

The scheduled refresh of the data coming from azure sql works fine for many months.
We didn't change anything in the data model in power bi and azure sql, nor there were any changes for any logins or security settings.

 

Since yesterday (27 July 2018) the data refresh always stops with an OLEDB/ODBC error. If you manually start the refresh again it stops with the same error. The table name where the error occurs is changing but thru SQL Mgmt Studio the table content is readable without any problem. Also manually refreshing the model with PowerBI Desktop (!) ends in the same result.

 

There must be a temporary issue in the data connection between Power BI and Azure SQL, which unfortunately cannot be reproduced with SQL Mgmt Studio. Thru this connection everything just works fine.

 

It's an issue, which the teams from Power BI and Azure SQL have to address together.
Thank you.

 

Michael

 

Last refresh failed: Sat Jul 28 2018 15:03:11 GMT+0200 (W. Europe Daylight Time)
There was an error when processing the data in the dataset.
Hide details

Message:The command has been canceled. Table: Immobilie.
Cluster URI:WABI-NORTH-EUROPE-redirect.analysis.windows.net
Activity ID:057d1a27-d76a-f03c-8089-8c5f26a6f2c1
Request ID:cbcebde1-27f8-0383-6196-b7d8c569c706
Time:2018-07-28 13:03:11Z

Invalid credentials on Sharepoint folder

Status: Accepted
by csabil Frequent Visitor on ‎11-22-2016 10:46 PM

Since yesterday I'm having an issue connecting to an excel file in a Sharepoint folder. It was already working, but I made some changes and republished it. Refresh works fine in Power BI Desktop, but online. It seem it's trying to connect to a Sharepoint list, instead of folder. I have an other report connecting to an other excel file in the same folder and it works fine. Could this be connected to the issue in North Europe? I'm in that datacenter.

 

Capture.PNG

Status: Accepted
Idea Statuses