New Idea

Missing / disappeared app in app workspace

Status: New
by pavel242 Frequent Visitor on ‎01-02-2019 08:37 AM

Over the holidays our app disappeared from the app menu and when accessed via direct link it says: We couldn't install "app name". (status code 400)

 

At least it's able to translate the ctid (http://https://app.powerbi.com/groups/me/apps?ctid=xxx) to app name.

 

I've searched the audit log and no updates / deletions or other activities appeared during second part of December. Btw. searching the audt log is quite tough, I ended up searching the acticities one by another, because when multiple of them were selected, I got 0 results but when just one was selected I got some results...

 

Pavel

Whenever the visual is a table that has many entries I'm not able to scroll with the mouse wheel or the keyboard on Firefox.

 

I'm currently using Firefox Quantum 62.0.3 (64-bit) and the version of Power BI Javascript client is 2.6.5 (also tested 2.5.0 and 2.4.7).

 

I would also like to show the scrollbar (which is not shown) whenever there are more records on the table than can be shown on the iframe.

Status: Accepted

Hello,

 

I am getting an error "Access to the resource is forbidden" when trying to access Microsoft Graph in Power BI Desktop report.

Microsoft Graph URL is https://graph.microsoft.com/v1.0/devices

I am logging in using Organization Account.

I have Global Admin role in the tenant.

 

The report was working normally for months, but stopped since yesterday.

I even tried creating new one - same result.

Accessing the same URL from Graph Explorer works fine.

 

What could actually impact this kind of error?

I try to get my table from my dataset in Bigquery into Power BI Desktop. But unfortnately I m getting to follwing error:

 

DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job first-projec:job_dm6z7i391YiYbOwjL7t-ydZ4V26dd6dfnv8
Details:
DataSourceKind=GoogleBigQuery
DataSourcePath=GoogleBigQuery
OdbcErrors=Table

 

I tried the following to lose this error:

- Changing this line in the M source code:

Quelle = GoogleBigQuery.Database(null)

to:

Quelle = GoogleBigQuery.Database([BillingProject="Billing-Project-Id"]) 

- I used the Simba ODBC driver as described here : Simba-BigQuery-ODBC-Driver-Quickstart2.pdf

 

Is this still a bug in Power BI?

 

P.S: my dataset and google cloud storage are in the same region, europ-west2

 

 

Fix the "Data Loading" / "Almost Done" issue

Status: New
by SMHolck Frequent Visitor on ‎10-02-2018 02:56 PM

Multiple people in my organization are unable to view published apps in our Power BI tenant.  They can sometimes click Apps and then wait for it to load forever.  You see a brief message "Data Loading" followed by "Almost Done."  And it will spin for hours.  My entire company has a Pro license.  The data loads fine in my Power BI desktop.  Issue happens on both IE 11 and Chrome 69.   Good thing I'm not currently doing my presentation on why you should use Azure!AlmostDone.png

 

I've seen this happen often and on.  You never know when it is going to happen.  My Azure admin says when he logs in to Azure portal it tells him no known outages.

 

 

We display PowerBI reports with the Microsoft embed library https://github.com/Microsoft/PowerBI-JavaScript in a custom web container.
Frequently, report tooltips are not correctly displayed.
 


As you can see in the screenshot, they take an - apparently fixed, ie 1280 - size, despite having set it up in the builder, both as 'auto' or the desired fixed size of 300ish px.

The report is inside an iframe so I doubt it has to do with the container CSS.

 

This bug seems to happen on all major browsers (FF, Chrome, Edge) but we never seen it in the pbi desktop app.
 
How can we ensure the tooltip is displayed as designed in the builder ?
Status: Needs Info

why powerbi app in web browser (firefox 2018) show multiple scroll that not appear in the power bi desktop when we design the page, i can't find where the option to disable this multiple scroll, please check and hire more manpower to take care powerbi, to much basic and simple bug.

These circled scroll bar is not appear in powerbi desktop, its really disturbing the view

sc.jpg

Status: Needs Info

Embedding set.pagefilter() not working

Status: Accepted
by Rich2852 Frequent Visitor on ‎09-10-2018 01:34 AM

This is currently not working: 

reportEmbed.min.js:1 Unhandled Promise rejection: Failed to execute 'postMessage' on 'Window': TypeError: Cannot read property 'instanceOfIVisualLevel' of undefined could not be cloned. ; Zone: <root> ; Task: Promise.then ; Value: DOMException: Failed to execute 'postMessage' on 'Window': TypeError: Cannot read property 'instanceOfIVisualLevel' of undefined could not be cloned.
    at e.sendResponse (https://app.powerbi.com/13.0.6617.130/externals/windowPostMessageProxy.min.js:2:3035)
    at https://app.powerbi.com/13.0.6617.130/externals/windowPostMessageProxy.min.js:2:4753
    at t.invoke (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:449376)
    at e.run (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:444540)
    at https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:455835
    at t.invokeTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:450060)
    at e.runTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:445234)
    at v (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:452421)
    at e.invokeTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:451223)
    at i.isUsingGlobalCallback.invoke (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:451082) Error: Failed to execute 'postMessage' on 'Window': TypeError: Cannot read property 'instanceOfIVisualLevel' of undefined could not be cloned.
    at e.sendResponse (https://app.powerbi.com/13.0.6617.130/externals/windowPostMessageProxy.min.js:2:3035)
    at https://app.powerbi.com/13.0.6617.130/externals/windowPostMessageProxy.min.js:2:4753
    at t.invoke (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:449376)
    at e.run (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:444540)
    at https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:455835
    at t.invokeTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:450060)
    at e.runTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:445234)
    at v (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:452421)
    at e.invokeTask (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:451223)
    at i.isUsingGlobalCallback.invoke (https://app.powerbi.com/13.0.6617.130/scripts/reportEmbed.min.js:1:451082)

 

See the demo for an example: https://microsoft.github.io/PowerBI-JavaScript/demo/v2-demo/index.html

 

 

Status: Accepted

Cortana not showing power bi cortana card.

Status: Accepted
by vsmani99 Visitor on ‎08-07-2018 10:44 AM

Cortana shows the power bi dataset, but not loading the powerbi cortana card report . it shows as loading.. while testing with powerbi.com/cortana/test also, it find the intepretations based on the utterence but not showing the cortana card at all. Can you please help? i can able to open other  powerbi dashboards without any issues using Cortana. Cortana card is not showing up.

 

cor1.JPGwhile typing net earnings, cortana shows the corresponding powerbi datasetcor2.JPGwhen we selected that, it kept showing as Loading

Status: Accepted

Select query in odata v4 is ignored

Status: Accepted
by agur Frequent Visitor on ‎01-31-2018 04:16 AM

When using $select in the query string for an OData v4 service it is ignored.

For example:

= OData.Feed("https://<org>.api.crm4.dynamics.com/api/data/v8.2/opportunities?$select=name,actualrevenue")

This returns all opportunities with ALL fields, not only name and actualrevenue

 

= OData.Feed("https://graph.microsoft.com/v1.0/groups?$select=id")

This returns ALL fields, not only group ID

 

This has a HUGE business impact, as this makes loading data in PBI reports extremely slow. The consensus in the Dynamics 365 environment is to export the data to an Azure database before loading it into PBI, which breaks security hierarchy and makes everything less user friendly.

Status: Accepted

Hello.
When I push a "Apply changes" button Power BI Desktop reports "This query contains transformations that can't be used for DirectQuery".
But my 'dataSource' query contains only decompression of BASE64 data string into Json data and transformation that into table.
That 'dataSource' query is used from extraction data tables by secondary queries.
If I click on any query from those queries I get a message "This step results in a query that is not supported in DirectQuery mode". When I push button "Switch all tables to Import mode" then It does change anything. I cannot get data into Power BI Desktop.
It is link to my problem file. link to a power bi project with that problem.

I used 2.61.5192.601 version.
Regards, Andrey Gritsenko.

Status: Accepted

The site (on all browsers) is not working.

 

Issue.png

Status: Delivered

I've noticed that the right-click drill-through is no longer working in published reports.     The menu doesn't appear on right-click.      It was working fine last week I believe

 

It works as expected in Desktop and also PBIS

 

 

Many of our users rely on the drill-though functionality to view line level detail

 

Hopefully it can be corrected soon

 

Thanks

Ryan

 

 

 

Status: Needs Info

AWS hosted Postgres -- Connectivity Issues

Status: Needs Info
by jc03701 Visitor on ‎08-07-2018 12:20 PM

Having trouble with intermitten connectivity to a postgres instance hosted by AWS.  It is similar to the outage experienced last week that was temporarily resolved. Can connect occasionally but not consistently.  Causing a huge pain for my organization.

Status: Needs Info

Web API data source refresh issue

Status: New
by SowjanyaK Visitor on ‎04-13-2018 01:16 AM

Hi Team,

 

I have created a web api which validates the http header and gives the response in Json format. I have added this api as a data source for a report in power bi desktop which is working fine. But when i publish the report to powerbi.com it fails the data refresh with an exception "Invalid Credentials" and the configured header value is not available in the data connection. need help in fixing this issue

 

Thanks 

Sowjanya

1. We created a sample report in Power BI Desktop and published in a Premium workspace. The report has been shared with a free Power BI user and the user was able to access the report from this link:

https://app.powerbi.com/groups/me/reports/a21dcaa9-6b35-402a-9ac4-f9111a95595e?ctid=705d07a3-2eea-4f...

We noticed that the above link opens the report from the "My workspace" (see the 1_Workspace_SharedLink.png) therefore the user is able to see the report. If the user wants to open the report from the workspace where the report was published then the message prompting for a Power BI Pro license is displayed.

2. The report has been embedded in MS Teams and the user was able to access the report there (2_MSTeams_Embedded.png).

3. When user click on "Go to website" in MS Teams the message prompting for a Power BI license is displayed (3_Prompt_ProLicense.png). The url for "Go to website" is https://app.powerbi.com/groups/89d3bf1c-72cf-4ff5-8eb2-4757342a749a/reports/a21dcaa9-6b35-402a-9ac4-.... We noticed that this link is also used when the workspace is accessed directly from Power BI Service.

The problem is that we would have liked that when user click on "Go to website" in MS Teams, the report to be opened in Power BI my workspace so user to be able to see it from there. Is there any possibility to implement this, or to allow configuration of the link from MS Teams? 

  1. 1_Workspace_SharedLink.png2_MSTeams_Embedded.png3_Prompt_ProLicense.png

Random semicolon in embedded report

Status: Delivered
by austeja Occasional Visitor on ‎09-20-2018 03:38 AM

I've recently noticed that there's a random semicolon in the embedded report's top left corner

semicolon.PNG

I've managed to track down the issue and it seems like there's a random semicolon left between the html tags. I believe this is a bug, a minor one although looks very annoying on the embedded report.

 

 

pbi2 - Copy.PNG

Status: Delivered

the latest rollout of a new feature (Analytics, Measure Drillthrough) has caused an additional section to show up on our embedded Power BI reports (we are using the filter pane). See screenshot with a dummy report embedded into our application - is there ANY way to disable showing the DRILLTHROUGH portion? It is already confusing our end users because they don't understand what to do with it (and they don't have the ability to "drag drillthrough fields here"). Please help!drillthrough showing in filter pane for end user.JPG

Status: Delivered

setSlicerState javascript method does not work

Status: New
by tval Frequent Visitor on ‎09-17-2018 06:51 AM

To see the error, just use the Power BI embedded demo site and try to set slicer filters.  Javascript error below. It didn't work most of last week, but then was working Friday.  Now doesn't work again.  I had posted in Developer forum, just re-posting in Issues area.

 

Capture.PNG

Hi,

After making the upgrade from PowerBI Desktop feb 2018 to june 2018 version, i can now no longer see functions in the odata Navigator. It only displays the "tables".

I tested on multiple computers and also with the below public odata service:

http://services.odata.org/TripPinRESTierService/

 

You can see in the screenshot left is excel(correct) and right is powerBI(missing functions).

Capture.PNG

Status: Accepted