cancel
Showing results for 
Search instead for 
Did you mean: 

The visualization in Server does not work correctly

I have the report published in Server and it worked correctly until yesterday (13 dec 2017). Now the report in Server is not correct, but in Power Bi Desktop it is okay. The screenshots of my problem: Server version (http://prntscr.com/hndy3j) and Desktop version (http://prntscr.com/hndyms). 
More details about my chart (http://prntscr.com/hneau9). It consists of two line: orange line is today`s data, the black line is an average of 3 previous weekdays (historical data). And in Server version, this historical data is less than it is actually.
I have republished the report and it has been working until the first refresh and then the report becomes incorrect again.
Also, I have updated Power BI Desktop and it also does not help.

Status: Needs Info
Comments
Moderator

Hi @vlnovikova,

 

Does the issue occur to this one specific report or all reports? 

Which data source does the report connect to? Please share detail steps for us to reproduce the issue. 

 

I would suggest you update the Power BI desktop to the latest version, then republish the report to Power BI service. 

 

Click Refresh Now for the dataset in Power BI service and Refresh button in Power BI desktop at the same time, then compare if those two results are the same. 

 

Best Regards,
Qiuyun Yu

 

 

Established Member
Status changed to: Needs Info
 
Visitor

Hi @v-qiuyu-msftThank you for your response!

1. Does the issue occur to this one specific report or all reports?

Yes, only this report. 

2. Which data source does the report connect to?

It is connected to ODBC (BigQuery and Navicat)

3. I would suggest you update the Power BI desktop to the latest version, then republish the report to Power BI service.

I have updated the Power BI and have republished the report to Power BI service. It has not helped.

4. Click Refresh Now for the dataset in Power BI service and Refresh button in Power BI desktop at the same time, then compare if those two results are the same.

I have done it. It has not helped too.

5. Please share detail steps for us to reproduce the issue.

It just has become incorrect 13 dec. I did not do any changes in this report.

Some more details about the report. Maybe this information will help you.

How I said earlier, there is the problem only with historical data (it is the black line on the chart and it is used for comparison of traffic) which calculates as an average of three weekdays. For example, today is Friday (15 Dec) then comparison line will calculate as (traffic of 8 Dec + 1 Dec + 24 Nov)/3.

And it seems that in service calculate as (traffic of 8 Dec + 0 + 0)/3. Really, I have checked it and I compared with only one weekday but divided on 3 (8 Dec).

Power BI service http://prntscr.com/hnv3ls
Power BI desktop (with only one weekday) https://prnt.sc/hntc6q. These charts are the same.

Can it be that service does not pull data for the early period?

Moderator

Hi @vlnovikova,

 

Would you please share the pbix file with us if possible? You can upload to your OneDrive and send the link to me via private message. 

 

Best Regards,
Qiuyun Yu

Visitor

Hi @v-qiuyu-msft

I have shared the ppbix file with you via private message.