cancel
Showing results for 
Search instead for 
Did you mean: 

Pendig changes: query metadata don't get updated

Hello,

I have some Power BI Boards which I edit once a month within the desktop app.

When I opened the boards yesterday I got a notification, that there are some pendig changes that have not yet been applied.

 

When I select "Apply changes", Power BI updates "query metadata":

Screenshot 2022-08-10 161652.png

For a moment a green tick is displayed.

However, the message "There are pendig changes" remains and I can't refresh my dataset.

 

When I select "Discard changes" nothing happens at all.

 

Does anyone know what are the pendig changes about? We didn't make changes to the dataset since last time.

How can I solve the pending changes to refresh my dataset?

Status: Delivered

Hi @MariaC 

I am so glad to hear that your issue has been fixed with other users' suggestions . At present, there are many problems with Desktop in August, so it is recommended to use the Version in July first, and then use it after the problem is updated in August . 

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Jay_Mitchel
Frequent Visitor

Hello all, 

 

This issue is due to the August release (which was automatically updated on 09/08). See another user having this issue: https://community.powerbi.com/t5/Desktop/August-Update-Issue/m-p/2693929

 

I reverted back to the July-22 version & my reports opened normally - without this issue.. 

 

Hope this is fixed soon. 

cdlawrence
Frequent Visitor

I had this issue too.

Even though I was able to get the message to go away, I could not load the existing dataset into a new report nor open existing reports based on the dataset.

 

I uninstalled Power BI and reverted back to the July version and I'm back to normal. I can load existing reports again as well as connect to the dataset in a new report.

 

You can find previous versions of the desktop here:

https://docs.microsoft.com/en-us/power-bi/fundamentals/desktop-latest-update-archive?tabs=powerbi-de... 

Steven_007
Regular Visitor

Ok i read on another post that they had a couple of parameters in power query that were causing the issue, i had a look at the 2 parameters my refresh was trying to up date and simply changed the value, refreshed and changed it back again and refreshed once more. This seemed to fix the issue for me. Good luck.

QuynhDam
New Member

Please any expert or Microsoft agent makes this clarify... Is this an bug? or new data structure/model requirement?

 

I did work around as advices but not fix the issue.

😩

Maia_Jin
Regular Visitor

Following @Jay_Mitchel and @cdlawrence solution (thanks so much! 😊), I reverted back to the July version and this works! I can successfully refresh my data sets and publish as usual.

Here's the download link to 

 

Hope this works for you too.

Ailsa-msft
Community Support
Status changed to: Delivered

Hi @MariaC 

I am so glad to hear that your issue has been fixed with other users' suggestions . At present, there are many problems with Desktop in August, so it is recommended to use the Version in July first, and then use it after the problem is updated in August . 

 

Best Regards,
Community Support Team _ Ailsa Tao

umutkoyun
Frequent Visitor

Yes, after August update it occurs.

I fix the issue : 

Edit Query ---> Refresh Preview some of them only. Never asked again... 🤞 I was lucky I guess )))

INTEP
New Member

I am getting crazy trying to find the problem during two weeks until I had found this post. I revert back also to the July version and works.

Unbelievable that Microsoft does not fix this problem until now, causing a lot of trouble!

Thanks for all!

edhans
Super User

This was fixed a week ago @INTEP in the last August maintenance release. No need to revert to July now.

Jay_Mitchel
Frequent Visitor

Hello @edhans  can you link any confirmation that the issue was fixed? I am still experiencing this metadata issue on the August version today.