0 Kudos

Multi-row card not displaying format string correctly

Status: Needs Info
by mothman Visitor on ‎01-30-2018 07:02 AM

Hi

 

I have noticed that the multi-row card does not take into account the format string of a field, whereas other visuals such as table and matrix do.  See screenshot below, on the left is the multi row card displaying these fields in the default number format, whereas on the right the same fields are in a table and the SSAS format string displays correctly (has been customised for Swedish krona currency). 

 

Modifying the format string in SSAS updates the format in the table on the right but has no effect on the multi row card.  There also doesn't seem to be a way to change the format in PowerBI, maybe because it's in live mode. 
I am connected to an SSAS database in live mode, using the latest PowerBI Desktop RS ver. 2.51.4885.2501 

 

Is this a bug or am I missing something?
Thanks!

multi row card vs table.PNG

 



format string.png

Status: Needs Info
Comments
by Moderator v-qiuyu-msft
on ‎01-31-2018 10:48 PM

Hi @mothman,

 

From the last screenshot, you set the format string for the measure [Budget YTD Diff]. Both in multi-row card and table visuals, this measure doesn't have "Kr" appended. 

 

As another two measures Vuxenintakt, Budget YTD values have "Kr" appended, how do you set the format string for these two measures? You can set the same format string for measure [Budget YTD Diff] as these two measures. 

 

Generally, we can set the format string as Currency on SSAS side. 

 

1.PNG

 

 

Best Regards,
Qiuyun Yu 

 

 

 

 

by Vicky_Song Established Member
on ‎01-31-2018 10:49 PM
Status changed to: Needs Info
 
by mothman Visitor
on ‎03-02-2018 03:16 AM

Hi @v-qiuyu-msft

Thanks for looking into this, I have updated the format string in SSAS, but the issue is that it's not being recognised by the multi-row card visualisations.

 

This is a side by side comparison of a table and multi-row card using the exact same fields.

The table displays measures and calculated members in the correct format string.

The multi-row card displays the calculated member correct but ignores the format string for the measures.

This seems like a bug?

 

Thanks
Moh

comparison.pngmeasure1.pngmeasure2.png

calculatedmember.png

 

Idea Statuses