cancel
Showing results for 
Search instead for 
Did you mean: 

Font and font size formatting in text box reset to default when swiching between tabs in PBI Desktop

I have set my font to Arial and the size to 10 in my text box in Power BI Desktop.

When I swich between the tabs, the formatting is reset (and default is shown).

 

I have recorded the steps I have done. The steps can be found at this link: link

Status: Needs Info
Comments
Helper III

goes back to default formating.PNG

Microsoft

@linekrogh

 

Are you using the latest May 2017 version (2.46.4732.721) of Power BI Desktop. I cannot repro the same issue on my side. Please refer to the video below.

 

 

Best Regards,
Herbert

Impactful Individual
Status changed to: Needs Info
 
Helper III

It is exactly the same I am doing. i do not know why I get this issue.

 

Yes, I am working with this version 2.46.4732.581 64-bit (maj 2017)

 

I have figured out it is also just some of the text boxes or with some text.

In the below window it seems like it is keeping some of the formatting of the text.

What I did, was taken the text. Cltr + X > dublicate the text box to the left and then inserted it again.Capture.PNG

 

 

Helper III

I have copy pasted the text in from Word.

The strang this is that it seems wrong in the below picture. However, if I deploy the report the format is I orginally made it. It is only If I change something with in the text box and I do not change the format - then the default format will be shown for some of the text.

 

 

 

recording steps - Capture.PNGCapture2.PNGhttps://www.dropbox.com/s/93iauoyo7opdbs5/Format%20issue2.zip?dl=0

Helper III
Advocate I

I am getting the exact same issue, one part (yes one part!!) of one text box keeps resetting to default font while the rest of the font remains what I have changed it to. I have changed it back and saved the item, deleted the box, retyped and started again and it continues to do this. Must be a bug in the text box visual that needs fixing. Please resolve.

Advocate II

I have the same problem, and it's driving me nuts! I have upgraded Power BI each month and this has been going on for months.  Anyone have an update and/or work-around on this??

 

Helper I

 I have also experienced the same problem.  After experimention, I've concluded that the problem occurs in the situation when a combination of bold/normal text occurs in a particular manner - namely where bold text is followed by normal text in the same line followed by a new line of text.

 

I created the following examples to demonstrate this:

 

PBI font change.JPG

Given this, I guess the only option - until Microsoft fix the problem - is to create your text in a manner that avoids this scenario.

 

Helper I

I am also having this issue and its been a year since this person original posted. This seems like a very, very rudimentary bug that should have been caught in QA. Anyone have a solution for this yet?!