cancel
Showing results for 
Search instead for 
Did you mean: 

Error to refresh an existent dataset but if I re-publish it with a different name it refreshs

Hi Everyone

I would like your help to figure out how the fix the following issue.

I had a dataset that was refreshing fine and that suddenly stopped to refresh. Im getting the following error message: The key didn't match any rows in the table. (The table name is different any time that I try to refresh). If I republish the pbix with the same name (ask to replace the dataset), I still get the same error message. If I rename the pbxi and publish it as a new dataset, I am able to refresh it with no issues. That dataset gets data from a few dataflows. I really appreciate if someone can help me with that.

Thank you

Status: New
Comments
Moderator

Hi @lcamposogl

 

Please download the report from the service, open the report in Power BI desktop, click on Refresh to see if the same issue occurs. Then republish the report to Power BI service, go to Dataset Settings, specify correct credentials for data source, then refresh the dataset again to check if there is any error.

 

Best Regards,

Qiuyun Yu