cancel
Showing results for 
Search instead for 
Did you mean: 

Embedded Report IFrame randomly not fully rendering

Some of our clients are having an issue with their reports not fully rendering (the filter panel shows up but the entire report area is blank).

When right clicking over the iframe and clicking "Reload frame", it then fully renders.

 

We are using powerbi-client-2.18.6 in an angular application.

It's happening in Chrome 95-96

 

I have not been able to reproduce this issue.

Does anyone have any familiarity with such a scenario?

 

 

 

 

Status: Investigating

Hi @RL2 

 

May I know whether they need to reload the iframe every time they view the report or just need to do it occassionally?

 

Best Regards,

Community Support Team _Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @RL2 

 

May I know whether they need to reload the iframe every time they view the report or just need to do it occassionally?

 

Best Regards,

Community Support Team _Caiyun

RL2
Regular Visitor

Hi @v-cazheng-msft 

 

Yes, every time the user navigates to the page to view the report, it shows up blank and they need to reload it manually.

 

thanks

 

jagatho
Frequent Visitor

I can reproduce this error directly in PBI Service in both Edge and Chrome.

I open a report in an A1 capacity, navigate to a different report and then back to the first report, then all visuals are gone. Even when I try editing the report afterwards.

If i refresh the browser everything is fine.

v-cazheng-msft
Community Support

Hi @RL2 

 

Thanks for your reply. I understand. May I know whether there are many visuals on your report page? If these users getting such issue switch to other browsers or network, will they get same issue?

 

Best Regards,

Community Support Team _Caiyun

jagatho
Frequent Visitor

It probably has to do with custom visuals. We are using Card with States by OKVIZ. If I change those to a standard card the issue is gone.

v-cazheng-msft
Community Support

Hi @jagatho 

 

Thanks for your reply. May I know whether standard Card viusal can meet your business needs? If you still need Card with States by OKVIZ visual, I think you may open a support ticket for further help.

How to create a support ticket in Power BI - Microsoft Power BI Community

 

Best Regards,

Community Support Team _Caiyun

jagatho
Frequent Visitor

I am sorry for hijacking this issue, I am not the creater of it.

I will create a support ticket, and then let RL2 reply based on their findings 🙂

v-cazheng-msft
Community Support

Hi @jagatho 

 

Sorry for making a mistake before. 😄 Thanks for your reply. I got it. 

 

Best Regards,

Community Support Team _Caiyun

RL2
Regular Visitor

Hi @v-cazheng-msft 

 

Some more info:

The issue is only happening with a few users.

The issue is happening (for sure) in chrome Version 96.0.4664.45 (Official Build) (64-bit).

In Edge the report is working fine.

 

Just to clarify what the user sees after the report is embedded and rendered in chrome

Below is the entire iframe, whatever is in red stays blank and whatever is in green is displayed.

Again when right clicking on the iframe and selecting 'reload frame' everything shows up

RL2_0-1638351999997.png

thanks

v-cazheng-msft
Community Support

Hi @RL2 

 

Thanks for your reply. I understand. This issue only takes place with a few users using Chrome browser. May I know if these users update their Chrome browser, will this issue be resolved?

 

Best Regards,

Community Support Team _Caiyun