0 Kudos

BUG: Publishing a report with the active page hidden

Status: New
by muneern Frequent Visitor on ‎12-18-2018 04:45 AM

When you publish a report to the Power BI service -- and the currently selected page in the report is marked as 'hidden' -- then the report is blank when you click on the link in the Power BI Service.

Comments
by Moderator v-qiuyu-msft
‎12-18-2018 06:14 PM - edited ‎12-18-2018 06:14 PM

Hi @muneern,

 

What do you mean about "then the report is blank when you click on the link in the Power BI Service."? Would you please share a pbix file use some dummy data so we can try to reproduce the issue? 

 

By the way, if we save the report on the hidden page in Power BI desktop, we open to the page that was open at last save. So on Power BI service, when we open the report, it will open the hidden page. 

 

Best Regards,
Qiuyun Yu 

by muneern Frequent Visitor
‎12-18-2018 09:29 PM - edited ‎12-18-2018 09:30 PM

Hi,

 

You are correct - and described the situation better than I did.

Surely the Power BI service should not display a 'hidden' i.e. blank page in the report (even if it was the last selected page in the report)?

 

Regards,

Muneer

by Moderator v-qiuyu-msft
on ‎12-19-2018 10:13 PM

Hi @muneern,

 

Not sure I understand your issue completely. There are two issues reported before about hidden report page, please check if your issue is the same as one of them: 

 

https://community.powerbi.com/t5/Issues/Issue-with-Hide-tab-functionality-in-reports/idi-p/343904

https://community.powerbi.com/t5/Issues/Hidden-pages-are-available-in-Service-through-quick-menu/idi...

 

Best Regards,
Qiuyun Yu  

Idea Statuses