Matrix Not Displaying When Publish Report to Server

Status: Accepted
by Trebor Frequent Visitor on ‎11-21-2017 04:02 AM

I have developed some reports in Power BI Desktop which include the martix visual. All visuals are displaying correctly when viewing the reports in Power BI Desktop, but when I publish and try to view report in the Server, the Matrix is not displaying any information. All other visuals seem to be working fine in the server, just not the matrix.

Status: Accepted
Comments
by DaveRuijter
on ‎11-21-2017 04:08 AM

I seem to have the same issues!

Started yesterday.

Even for reports uploaded longer ago.

 

Data Source for these reports is SSAS (Live Connection).

by GTull Frequent Visitor
on ‎11-21-2017 04:45 AM

Exactly the same! Nightmare!

by HenriKr Occasional Visitor
on ‎11-21-2017 05:51 AM

I deleted my report and published it again: the matrix works fine again. Maybe you can try this work around.

by Moderator v-qiuyu-msft
on ‎11-21-2017 09:42 PM

Hi all,

 

The issue already reported internally: CRI 52200056. Current update from PG team: 

 

We have the fix ready, I will update with ETA later today. Hopefully we can roll this out over the next 5 days, but it might not hit Production until next week Monday/Tuesday.

 

Best Regards,
Qiuyun Yu

by Vicky_Song Established Member
on ‎11-21-2017 09:42 PM
Status changed to: Accepted
 
by NeossITAdmin Visitor
on ‎11-29-2017 05:02 AM

I have the same issue when using the Transform / Split column function.. Its frustrating when trying to use those reports for maintainance of SSRS schedules and Usage

by Moderator v-qiuyu-msft
on ‎12-01-2017 03:25 AM

Hi all,

 

The issue should be fixed now. Please test again to see if teh issue is gone. 

 

Best Regards,
Qiuyun Yu

by dagurkuden Frequent Visitor
‎12-06-2017 10:50 AM - edited ‎12-06-2017 11:11 AM

hi all


Some functions does not work  like dateadd,totalmtd,totalytd etc.  in direct query mode

 

It is not just about matrix.

And I  wanna say everthing works at Power BI Desktop RS .The problem starts when I published  to the Report server.

 

Also marked 

 

Capture.PNG 

 

 

 MdxScript(Model) (19, 33) Function 'DATESMTD' is not supported in DirectQuery mode. 

Datesmtd.PNG

by Moderator v-qiuyu-msft
on ‎12-07-2017 12:59 AM

Hi @dagurkuden,

 

The issue you reported seems different from this thread topic. As the issue happens in Power BI report server, I would suggest you post a thread in Report Server

 

Best Regards,
Qiuyun Yu

Idea Statuses