cancel
Showing results for 
Search instead for 
Did you mean: 

All data from power platform dataflows in my workspace broken started 22 April 2021

All the data from power platform dataflows that works perfectly a day before, giving error:

Expression.Error: The column 'entityName' of the table wasn't found.

since 22 April 2021.

 

The same dataflows have been working perfectly fine since January 2021.

 

Status: New
Comments
smpa01
Super User

Power BI team can you please look at restoring PowerPlatform.Dataflows conenctor on urgent basis. Currently, the outage has resulted in cascading failures of my reports for my client portfolio. Please help ASAP.

Dansky
Frequent Visitor

I'm also having the same issue. This is having a really adverse affect on each of my client's reporting portfolio. The issue is made worse by the fact that Dataflows were implemented by my recommendation since they are out of beta for a long time now. 

My current architechture development and reports in production are suffering due to this outage/issue and I've no acknowledgement from MS to source for this issue, only these posts. 

Tony_Jennings
Regular Visitor

@cvillegas  Did they ever get back to you?  I'm about to submit a ticket myself.  I have several Power Apps that are being affected by this bug right now.

cvillegas
Advocate III

@Tony_Jennings They did a few times just saying the team sees it as an issue and the issue has been escalated, but still no ETA. We have two PowerApps that are critical and one that is in POC we need to demo that don't function because of this and we have to rewrite with AZ Data Factory and bring the data into the dataverse instead. It's not a good sign.

😞

 

Even testing with the Power BI and specifically the Power Platform Connector I see the same issue. Pretty bad. I asked our TAM about it, but she's in the same boat waiting for an ETA.

Dansky
Frequent Visitor

@cvillegas  I can state with certainty that pushing to the dataverse in Power Apps is not working either the same error appears.

huic
New Member

 

The solution suggested by you doesnt work as i do not have any entity with column name 'entityName' in my data. Moreover, the dataflow has not been change at all, and the same dataflow is refreshing prefectly well using the same data before the date mentioned.

smpa01
Super User

 @v-robertq-msft can you please give an ETA on the resolution on this issue. Currently I manage 50+ dataflows and some of the dataflows use PowerPlatform.Dataflows to call other dataflows as using this connector only an existing dataflow can be edited within another dataflow. This 50+ dataflows in turn are queried within 50+ reports that I manage, and for optimization, a big chunk of my report query the SSAS table deployed through Power BI reports in Power BI service, currently more so through new Composite models. Since PowerPlatform.Dataflows is not working it is affecting the DFs that refence other DFs+the reports that call those DFs+reports that query SSAS tables that queries those DFs. I manage so many time sensitive reports that a small failure can have major impact in the whole portfolio, like it is happening now. Can you please give me something to go back to my stakeholders with that information. I am completely in dark with this issue at this point while I have massive report failures causing cascading frustration from the stakeholders. Please help.

mikesmith_bp
Frequent Visitor

@v-robertq-msft, my Dataflows have been broken since Friday and I have yet to see any official announcement from MSFT acknowleging this problem.  Is there an error log I can point my management to?

cvillegas
Advocate III

Big question for everyone we're trying to determine. Does everyone on here have the Enhanced Compute engine enabled? Is everyone on PBI Premium or Standard/Shared?

smpa01
Super User

@cvillegas  me on Premium Capacity, not sure about Enhanced Compute engine enabled