cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
keontre
New Member

Report is auto trimming text

Hi,

 

I am new to Power BI and have been trying to get a P&L statement report created.  The data I receive is already grouped in the accounts, I just need to display them in a meaningful way.  In order to distinguish between the header and detail lines in the P&L, I just added the following basic DAX:

 

PL DISPLAY = IF(PL_STRUCTURE[DISPLAY]="Detail", CONCATENATE(" ", PL_STRUCTURE[PL LINE DESC]), PL_STRUCTURE[PL LINE DESC])

The data then looks like the below in the preview window:

 

power_bi_preview.PNG 

 

When I add it to a table though, the leading white space disappears:

 

power_bi_report.PNG

 

I have spent a long time looking through settings in Power BI and forum posts, but couldn't find anything on Power BI auto trimming text in the reports.  During my research into creating P&L report structures I did find an example where they managed to do this (The BI Accountant).  I got a copy of their PBIX and added my data in the exact same way as before.

 

power_bi_report_working.PNG

 

So it can be done, and looking through document-level settings did not show any reason for why the behaviour was different between the 2 files.  The query part was simple - load from an Excel file and do nothing else to the query.

 

Any suggestions on stopping this apparent "auto-trimming" of text in reports?

1 ACCEPTED SOLUTION
ElenaN
Resolver IV
Resolver IV

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

2 REPLIES 2
ElenaN
Resolver IV
Resolver IV

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

Thank you ElenaN, that resolved the issue.  So simple, yet just not that obvious!  Smiley Very Happy

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.