cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
keontre
New Member

Report is auto trimming text

Hi,

 

I am new to Power BI and have been trying to get a P&L statement report created.  The data I receive is already grouped in the accounts, I just need to display them in a meaningful way.  In order to distinguish between the header and detail lines in the P&L, I just added the following basic DAX:

 

PL DISPLAY = IF(PL_STRUCTURE[DISPLAY]="Detail", CONCATENATE(" ", PL_STRUCTURE[PL LINE DESC]), PL_STRUCTURE[PL LINE DESC])

The data then looks like the below in the preview window:

 

power_bi_preview.PNG 

 

When I add it to a table though, the leading white space disappears:

 

power_bi_report.PNG

 

I have spent a long time looking through settings in Power BI and forum posts, but couldn't find anything on Power BI auto trimming text in the reports.  During my research into creating P&L report structures I did find an example where they managed to do this (The BI Accountant).  I got a copy of their PBIX and added my data in the exact same way as before.

 

power_bi_report_working.PNG

 

So it can be done, and looking through document-level settings did not show any reason for why the behaviour was different between the 2 files.  The query part was simple - load from an Excel file and do nothing else to the query.

 

Any suggestions on stopping this apparent "auto-trimming" of text in reports?

1 ACCEPTED SOLUTION

Accepted Solutions
ElenaN Resolver IV
Resolver IV

Re: Report is auto trimming text

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

2 REPLIES 2
ElenaN Resolver IV
Resolver IV

Re: Report is auto trimming text

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

Highlighted
keontre
New Member

Re: Report is auto trimming text

Thank you ElenaN, that resolved the issue.  So simple, yet just not that obvious!  Smiley Very Happy

Helpful resources

Announcements
New Ranks Launched March 24th!

New Ranks Launched March 24th!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power BI Community!

‘Better Together’ Contest Finalists Announced!

‘Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Arun 'Triple A' Event Video, Q&A, and Slides

Arun 'Triple A' Event Video, Q&A, and Slides

Missed the Arun 'Triple A' event or want to revisit it? We've got you covered! Check out the video, Q&A, and slides now.

Join THE global Microsoft Power Platform event series.

Join THE global Power Platform event series.

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities.

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors