cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lachicazul
Frequent Visitor

You do not have access to your data source via an Enterprise Gateway

Good afternoon and happy new year.

I'm testing the Enterprise Gateway with a SSAS data source but I cannot visualize my report in PowerBI

These are the steps I followed:

1. I have installed the Enterprise Gateway on the same AS server.

2. The gateway is configured and a data source is added to it. The credential used has server administration rights on the SSAS Server and belongs to the Admin Role in my OLAP DB.

3. I have built a new report using Power BI Desktop (using the option "Explore live"). It works fine. 

 

4. I have published the report successfully but I'm not able to open it in PowerBI: Report could not access the data source because you do not have access to your data source via an Enterprise Gateway

 

On top of that, when I try to open the Power BI Enterprise Gateway directly from Start I have an error message as well: 'Failed to contact gateway service"

 

What am I doing wrong?

 

I'm not sure if this is a clue: I don't have the same password for my AD account and my PowerBI account. Still, the user is the same:

companydomain\user (AD) and user@companydomain.com (Power BI). 

 

Thanks in advance 🙂

6 REPLIES 6
NikolajP
New Member

Had a similar problem, it helped to just delete all affected reports and connections on PowerBI.com and publish the same reports again. Guess its some problem related to the reports beeing on PowerBi.com over the course of an update. 

Greg_Deckler
Super User IV
Super User IV

I realize that this is for the Analysis Services connector but the same basic troubleshooting should apply:

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-admin-analysis-services-connector-indepth/

 

First, make sure you have a Pro account.

 

Second most probable would be something to do with your firewalls and connectivity between the gateway and Power BI service.

 

The error does not point to credential issues, it sounds more like it can't see the gateway but it could be some sort of credential issue, that link above will explain how those credentials get translated.


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




The issue only occurs to non-admin users.

I am facing the same issue here. Just wondering whether the threadstarter have managed to solve his issue? Is this issue caused by the need of opening outbound connections to the domain names and ports stated in the link below?

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-gateway-enterprise-indepth/

I face the same issue.

EnterpriseGatewayConfigurator.exe /Troubleshoot

 

Capture.PNG

Configurator hanging:

Capture1.PNG

Tried with Firewall on/off. Explicitly enabled firewall rule outbound port 443. Same result.

Any ideas?

Getting the same error message, the eneterprise gateway works fine with DirectQuery to the normal database but not when connecting to Analysis Services...

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Top Kudoed Authors