cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jrbrown00
Helper I
Helper I

multiple slicers for two visuals

I have 5 slicers and 2 visuals on a report.  I want 5 slicers to apply to Visual1 and 4 slicers to apply to Visual2.  Visual2 will have  the 5th field hardcoded and should not use the slicer.  The instructions seem straightforward, but I cannot get visual2 to ignore slicer5. 

 

Here is the screenshot for the visual1 setup. 

  • Visual1 is selected
  • Visual1 will use all 5 slicers (red outline1)
  • Visual2 will ignore changes to Visual1 (red outline2)
  • This works, all slicers control the appearance of Visual1

jrbrown00_0-1642186012112.png

 

Here is the screenshot for the Visual2 setup

Visual2 

  • Visual2 is selected
  • Visual2 will ignore the slicer labelled _type_ (red outline3)
  • Visual1 will ignore changes to Visual2 (red outline4)
  • Visual2 is filtered to show only _type_=1011
  • This does not work.  Visual2 is displaying the _type_ shown in the slicer.

jrbrown00_1-1642186366352.png

What am I missing?

1 ACCEPTED SOLUTION

Outline3 means that you are preventing Visual2 from filtering _type_ slicer. You are correct for Outline4.

 

A slicer is just another visual, so the controls are not reversed for these. It works the same as one matrix filtering another matrix. To prevent a slicer from filtering a matrix, you need to click on the slicer and click the 'do not filter' icon for the matrix.

View solution in original post

4 REPLIES 4
AlexisOlson
Super User
Super User

I think you might have your controls backward. In order for _type_ slicer to not filter Visual2, you need to click on the _type_ slicer and turn off filtering on Visual2.

 

What you currently have is that Visual2 won't filter _type_ or Visual1.

It is my understanding that the filled in 'do not' in outline3 means that Visual2 will not use the _type_ slicer and that the filled in 'do not' in outline4 means that Visual2 will not honor any selections in Visual1.

Currently, Visual2 seems to be 'anding' both the _type_ slicer and the hard-coded filter inside Visual2.

Thoughts?

Outline3 means that you are preventing Visual2 from filtering _type_ slicer. You are correct for Outline4.

 

A slicer is just another visual, so the controls are not reversed for these. It works the same as one matrix filtering another matrix. To prevent a slicer from filtering a matrix, you need to click on the slicer and click the 'do not filter' icon for the matrix.

You are correct.   That fixed my problem. The _type_ slicer is just another visual.  Click on the _type_ slicer and then click  on the 'do not' icon so that Visual2 is not filtered based on the _type_ slicer.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors
Top Kudoed Authors