cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
YoshiCoppens
New Member

Power BI Azure Databricks Connector: DirectQuery no working

Whenever I try to connect in Power BI via the Azure Databricks connector, the normal import mode works fine but DirectQuery does not seem to work. The error that appears is the one from the screenshot below. 

 

Screenshot 2020-09-25 143355.png

In the docs about the Azure Databricks Connector (https://docs.microsoft.com/en-us/azure/databricks/integrations/bi/power-bi) it mentions that DirectQuery should work but that seems not to be the case. When comparing the screenshot of the tables on the documentation page and my own screenshot of the tables, I do notice some differences, the fact that there is “http://” before and “:443” after “region.databricsks.net” but if I try adding those in the setup, I get errors for the domain name. The other noticeable difference, is that I have a folder called SPARK which includes multiple other folders where the doc screenshot show no folder and immediately tables.

Screenshot 2020-10-13 084725.png

Can anyone help me here? Is this a known bug? Can I report it someway? This is really stopping one of our use cases.

 

1 REPLY 1
v-alq-msft
Community Support
Community Support

Hi, @YoshiCoppens 

 

Here is a similar thread about using DirectQuery in Azure Databricks. Azure databricks with DirectQuery isn't listed in the supported source in the document . 

 

Best Regards

Allan

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!