cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
peytonmcbrayer
Helper I
Helper I

Error Retrieving Power BI Service sources: sequence contains more than one matching element

After updating to the November 2017 build this morning, I am no longer able to select Power BI Service data sources in Power BI Desktop.  The error in the screenshot below pops up immediately every time.  I tried uninstalling and re-installing, rebooting, etc.  I haven't found a way to clear the error.   I'm dead in the water until I can get this fixed.

 

PBI Error.PNG

1 ACCEPTED SOLUTION

Hey guys I posted this on the issues  forum as well.  MS answered last night.  They will be deploying the fix next week.

 

https://community.powerbi.com/t5/Issues/Cannot-Load-Power-BI-Service-Data-Sources-Sequence-Contains-...

 

View solution in original post

9 REPLIES 9
hoffmanrat
Frequent Visitor

I know that this says solved, and that there was an apparent fix applied in December, but I'm receiving this error now with Version: 2.55.5010.621 64-bit (February 2018). Anyone else?

 

I receive this error when trying to add a new datasource in DirectQuery mode.

 

It's a strange error exception message to receive as it doesnt suggest what is actually wrong and there is both no technical detail provided in the error message and nothing online. All I can assume is that there is something broken with the service.

I'm having this exact issue too. Has any body made any progress? I can't add any new queries to my report, which is a blocking issue.

 

I've sent in a frown bug report.

 

Edit: Well, as is the way of life, after posting and sending in the bug report I thought of something. I deleted all the existing queries and I was able to re-add everything including my new ones and so far so good. 

 

So, as a work around, delete existing queries and re-add everything. Fun.

kurtdn
Advocate I
Advocate I

I have the same issue !!! 

Anonymous
Not applicable

I have the same issue.

 

I know that when my organsiation signed up to Azure/Power BI; I origianlly had problems with there being apparantly 2 accounts for me (I used the same email address for my trial before we signed up to MS).  I wonder if this is causing the problem?

 

I have a service account; I did manage to connect to the BI Service with no issue from PBI desktop when using this account, further supporting my theory.

 

Anbody solved this?

Hey guys I posted this on the issues  forum as well.  MS answered last night.  They will be deploying the fix next week.

 

https://community.powerbi.com/t5/Issues/Cannot-Load-Power-BI-Service-Data-Sources-Sequence-Contains-...

 

View solution in original post

peytonmcbrayer
Helper I
Helper I

I ran a Fiddler to capture the JSON from the app when it calls out to the service to get the available sources, and there is an ID that is duplicated for my personal workspace.  I'm sure that's it.  Does that mean there's a bug in the service?

@peytonmcbrayer,

Do you use the latest version of Power BI Desktop(2.52.4921.682)? I can successfully connect to Power BI Service dataset in this version of Power BI Desktop.

In your scenario, I would recommend you click “Send a Frown” to report this issue, it seems that there are some issues with your workspace.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I sent a frown FYI

Yes, I have the latest build 2.52.4921.682 64-bit (November 2017)

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Top Solution Authors
Top Kudoed Authors