Showing results for 
Search instead for 
Did you mean: 

Cannot Load Power BI Service Data Sources: Sequence Contains more than one matchin element

After updating to the November 2017 build this morning, I am no longer able to select Power BI Service data sources in Power BI Desktop.  The error in the screenshot below pops up immediately every time.  I tried uninstalling and re-installing, rebooting, etc.  I haven't found a way to clear the error.   I'm dead in the water until I can get this fixed.  I used a sniffer to get the json coming back from the service, and there are two instances of the same workspace/group in the file.  It looks like the service is returning bad data.  HELP!!!



Status: Accepted

Hi @peytonmcbrayer,


I have reported this issue internally: CRI 52375764. Will update here once I get any information. 


Best Regards,
Qiuyun yu

Established Member
Status changed to: Accepted

Hi @peytonmcbrayer,


The fix will start being deployed to PROD on 12/4 (all PROD by 12/9 at the latest).


Best Regards,
Qiuyun Yu

Not applicable

I have the same issue, but also cannot use the "Publish" button (PBI does nothing, no error, nothing).


Whilst trying to reolve my issue outlined in this thread, I realsied that I could connect to the PBI Service via PBI dektop using one of my "service accounts".  So this supports the theory of some form of duplication (I think it is accounts rather than workspaces).


So I have also tried to "Publish" a report from PBI desktop using the same service account; works no problem.


This suggests to me that the issue relating to the failure to connect to the PBI Service via PBI desktop also relates to the issue I am expereincing re publishing from PBI desktop.


Any ideas?

Regular Visitor

 @Vicky_Song  This is resolved.  Thanks.