cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SilvaEric1
Regular Visitor

AWS Postgres: 'The remote certificate is invalid'

Hi All, 

I've tried the attached instructions, but I'm still receiving the following error message when trying to connect to AWS RDS Postgres.

Details: "An error happened while reading data from the provider: 'The remote certificate is invalid according to the validation procedure.'" 

Since that post is a couple of years old, I thought I'd ask if there are any additional items to look for? I've installed the latest version of npgsql and imported the AWS RDS Certificates. I'm able to successfully connect to the Database via PgAdmin so it's not an account issue. Any help would be appreciated! 

Thanks, 

Eric

10 REPLIES 10
dustout
Advocate I
Advocate I

I ran into the same error, and disabling encryption will also make that error go away. 

 

To disable encryption

  1. File --> Options and settings --> Data source settings
  2. Click Edit Permissions on your connection
  3. Uncheck Encrypt Connections

Hello. Can you help please as when I do the above steps it gives the same error and when I go to edit permissions I find it checked although I unchecked it before?

Sorry, I'm a bit confused.  On step #2 where I'm supposed to click on "Edit Permissions" on my connection, I don't have a connection because of the error I'm getting.  How do I get it to ignore the error and create the connection anyhow so that I can update the Permissions?

In my case I was able to add the connection through the standard "Get Data" and then "Postgresql" data provider, and ran into this after adding it. What does the error you get when adding the new connection? 

This worked. Thank you so much for telling a very simple step.

I literally made an account to just upvote this post. 

 

I was about to run go down a coding rabbithole to tackle this issue.

Anonymous
Not applicable

Thank you for your post bro, It helped me to solve this problem.

Anonymous
Not applicable

I was also stuck with this issue today. The solution might be obvious to some people but I think it's not clearly mentioned in the other conversation. If you have done everything that is mentioned in the linked instructions than one more thing you should check is that are you using the qualified domain name when connecting to AWS. By this I mean something that ends with ...amazonaws.com. I think you just can't use aliases with the AWS certificate. I didn't invent the solution but happened to stumble on it in this community conversation.

tarunsareen25
Frequent Visitor

@SilvaEric1 Were you able to find a solution or a workaround for this? We are stuck with the same problem

v-lionel-msft
Community Support
Community Support

Hi @SilvaEric1 ,

As tested, I can't reproduce the problem you encountered, please create support ticket .

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
collabdays lisbon

CollabDays Lisbon - 26 November 2022

Sessions include practical, hands-on experience that will help you take the next step in your career and know-how.

Difinity Conference

Difinity Conference 2022

Difinity is the largest Microsoft Data, AI, Power BI, Power Platform and Business Applications Conference in New Zealand.

European Share Point Conference

European Share Point Conference

This conference returns live and in-person in Copenhagen this 28 November-01 December with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.