cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

'Unable to connect to data source undefined'

Trying to refresh a dataset from 3 different sources - two are databases within the same server and then one additional server. All have been set up with the gateway I'm using.

 

I haven't seen the error I'm receiving 'Unable to connect to data source undefined' anywhere online.

 

Has anyone seen this before? I have tried refreshing a dataset from each of the sources individually with no issues.

28 REPLIES 28
naivecalf
Helper III
Helper III

for me it is worked after I changed privacy level and updated gateway to latest version.

mailfalanyok
Frequent Visitor

Making all privacy settings at dektop and service to "Organizational" fixed this for me too.

rynhowl
Microsoft
Microsoft

Making all privacy settings "Organizational" and updating my gateway worked for me.

Jayendran
Solution Sage
Solution Sage

There are several reasons for this. I shared my experience on how I fixed this and wrote an article in the community. Please refer below link. 

 

https://community.powerbi.com/t5/Community-Blog/PowerBI-intermittent-Refresh-Failure-Unable-to-conne...

 

Hope this helps some one.🙂

RichardGAO
Advocate I
Advocate I

Can anybody help to resolve the issue in PBI Service? The issue has been reported in many places of Internet, but never got fixed. Thanks. 

 

My data source is only from OData API, using Import mode. Refreshing succeeded in PBI Desktop but failed in PBI Service, so I consider the issue is at gateway or PBI service self. Thus, I reinstalled both standard and personal modes of gateway, reinput the credentials, and even republished the pbix file on PBI Service ... does not work yet. 

 

The tables are different, but error message and error code are always same.

 

Something went wrong

Unable to connect to the data source undefined.

Please try again later or contact support. If you contact support, please provide these details.

Underlying error code: -2147467259 Table: DocumentToProtocolRelationships.

Underlying error message: OData: Request failed: Unable to connect to the remote server

DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259

Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error

Cluster URI: DF-MSIT-SCUS-redirect.analysis.windows.net

Activity ID: 84726276-12ae-46cb-b636-b1a81fe4c0fe

Request ID: 436e8798-ef78-40fb-b5c2-24fafc412259

Time: 2019-10-02 00:17:05Z

 

Something went wrong

Unable to connect to the data source undefined.

Please try again later or contact support. If you contact support, please provide these details.

Underlying error code: -2147467259 Table: Implementations.

Underlying error message: OData: Request failed: Unable to connect to the remote server

DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259

Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error

Cluster URI: DF-MSIT-SCUS-redirect.analysis.windows.net

Activity ID: 3e3e62d0-d5af-4022-a19f-828ad65d7078

Request ID: 74c1a014-4cd6-4c10-831f-c53f485cf78a

Time: 2019-10-01 16:19:10Z

 

My reports have been working well on PBI Service for long time, but now cannot refresh successfully with the following error message always:

 

Last refresh failed: Tue Oct 08 2019 14:32:21 GMT-0700 (Pacific Daylight Time)
Unable to connect to the data source undefined.Hide details

Underlying error code:

-2147467259 Table: Products.

Underlying error message:

OData: Request failed: Unable to connect to the remote server

DM_ErrorDetailNameCode_UnderlyingHResult:

-2147467259

Microsoft.Data.Mashup.ValueError.Reason:

DataSource.Error

Cluster URI:

DF-MSIT-SCUS-redirect.analysis.windows.net

Activity ID:

6029d4c4-55f3-4928-b640-229166fe5d14

Request ID:

e2edc094-9a1a-6907-4632-e8d4d5ff3330

Time:

2019-10-08 21:32:21Z

 

Last refresh failed: Tue Oct 08 2019 15:15:18 GMT-0700 (Pacific Daylight Time)
Unable to connect to the data source undefined.Hide details

Underlying error code:

-2147467259 Table: ProtocolToChildProtocolRelationships.

Underlying error message:

OData: Request failed: Unable to connect to the remote server

DM_ErrorDetailNameCode_UnderlyingHResult:

-2147467259

Microsoft.Data.Mashup.ValueError.Reason:

DataSource.Error

Cluster URI:

DF-MSIT-SCUS-redirect.analysis.windows.net

Activity ID:

6029d4c4-55f3-4928-b640-229166fe5d14

Request ID:

c3350f39-ee6a-6bf5-665b-4cd1b3f5fdeb

Time:

2019-10-08 22:15:18Z

 

It  is able to refresh successfully from PBI Desktop, but cannot refresh from PBI Service. Even though refreshed the same dataset multiple times, I got the same error code(-2147467259) on different tables above. The error "Unable to connect to the remote server ( error code: -2147467259)" was prompted multiple times in lots of articles from Internet, inculding the PBI community, but looks never be resolved?  

 

Certainly, I doubt some issue in Gateway, and verified the Gateway network connection successafully. However, I cannot find any *.zip log file under relevant folders at all after clicking the 'Export Logs' link from the App UI (I submitted another post for this problem). 

 

fcbadmir
New Member

I received the same issues and was able to fix it. I updated my gateway to the latest version and refreshed my credentials [in Datasets > click on dataset > Data source credentials > Click edit credentials and sign in]. After that, the refresh worked fine.

SoniaB102
Frequent Visitor

Also getting that error message, among others.  We have a multiple datasets refreshing daily and they fail for different reasons at different times.  We autorefresh datasets using an on-premise gateway. It has been going for over 6 months.  You may want to try all the things we have tried in case that helps:

 

  • Set Privacy Level to Organizational
  • Made sure all reports are refreshed at different times
  • Created another on-premise gateway to split the load
  • Created database tables rather than views to reduce processing between PowerBI and MSSQL
  • Ensured both desktop and gateway has the latest version installed at all times

 

 

  • Set Privacy Level to Organizational
  • Made sure all reports are refreshed at different times
  • Created another on-premise gateway to split the load
  • Created database tables rather than views to reduce processing between PowerBI and MSSQL
  • Ensured both desktop and gateway has the latest version installed at all times

Great list, Sonia!

 

 

 

After the June 2019 update...
* remove orphaned queries with old data sources even if they don’t in any way get loaded (always a good idea)
* make sure if hitting two databases that they use the same windows credentials.
* remove any queries that trigger the “”hand authored queries” warning

Thanks @freder1ck.  I don't beleive that would have been the cause of the refresh because:

* I don't think we would have orphaned queries
* Most dashboards only use one database
* I have never seen this error: “”hand authored queries” 

 

However potentially this will work for other people.

 

In the end, we built a script and a lambda that refreshed each dashboard every morning rather than using scheduled refresh in powerbi.  This script keeps trying to refresh until successful.  Since building that script we do not often have to try more than once to refresh and have no errors.

Anonymous
Not applicable

Please also note that this error can occur with multiple underlying reasons.

 

Yours is "XXXXXXX is not able to access the database "XXXXXX" under the current security context."

 

Mine gives me a detail of "OLE DB: Query timeout expired"

 

 

Seb_Still
Regular Visitor

Hey,

 

I am currently operating several reports using the on-premise gateway.

The reports see a scheduled daily refresh in the morning. Until sunday, everything went quite well, with few issues over time.

But since sunday, no scheduled refresh succeeded, promting the "Unable to connect to data source undefined" Error.

 

I tried running the embedded queries (the reports pull data from one data warehouse and multiple tables in it) manually using the MySQL Workbench, yet, those queries did not succeed. Since they havent been changed after uploading the reports to the cloud, I must assume that the error is caused on our end of the line (software changes, network changes). However, I havent been able to solve the issue until now, still searching for the root cause of the issue.

 

Are you aware of any changes to your local infrastructure (network, databases, software)?

 

Best

Seb

Anonymous
Not applicable

I am now getting the following error message repeatedly when trying to manually refresh the dataset:

 

'Scheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh.'

 

I can't change the credentials because no gateway is appearing, and I know they're correct in desktop.... 

Anonymous
Not applicable

The issue was temporarily resolved but now I'm receiving a range of different error messages in quick succession.

 

In the last five minutes I've received the following errors when trying to refresh the dataset:

 

'Failed to load data source. Please try again later'

'Failed to load model for refresh. Please try again later'

'Refresh failed because this dataset requires a gateway. Please select a gateway from dataset settings'

 

I also received one saying one or more data sources was missing credentials (they're not)...

nickelous
Frequent Visitor

I had an incorrect database name on my data source. my issue is resolved. 

Imtiaz_Abbas
Regular Visitor

Hi Folks,

I am getting the same error for last 4 weeks. This error is not related to a particular report. I am having this error for 7, 8 reports daily. It's very frustrating. Please help us to resolve this issue.

Privacy settings isnt solving problem. Even created a new report with latest desktop version and still no luck. Do not know what to try next.

I don't know what to try either. Some of mine refresh fine, some fail. The next day they succeed and others fail. No idea what the issue is. I was thinking it is something to do with our server, but not after I see that so many are having the same error.

Meiss_DataSci81
Regular Visitor

I had the same issue. In my case the problem were different privacy level settings in Power BI Desktop and Power BI Service. Make sure you have the same privacy level security:

 

In Power BI Desktop:

 

Options and Settings --> Data Source Settings

For every Datasource: -->  Edit Permissions

Set Privacy Level: e.g. „Organizational“

 

Power BI Service:

 

Datasets --> (Choose you Datasets which does not update properly) --> settings --> Gateway Connection --> Actions --> (expand you cluster to show all Data Sources) --> (Choose relevant Datasource) --> Advanced Settings --> Privacy setting --> set same level (e.g. „Organizational) as in Power BI Desktop

 

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors