cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jishadshajahan
Frequent Visitor

The credentials provided for the Web source are invalid.

Hello,

 

My Application is using One drive excel files as datasource, but it fails on refreshing.

I am facing an issue with Power BI Cloud , the data is not refreshing, the automatic update fails and it is showing the error "The credentials provided for the Web source are invalid." and when  I tried to update the credentials it is showing the below error.

 

Failed to update data source credentials: Hide details

Activity ID:8059133c-47e7-4c9e-8755-d944868ae572
Request ID:1d44c9cb-e6f3-7b70-13b9-9cc3d33ed19a
Status code:400
Time:Fri Oct 18 2019 05:26:38 GMT+0530 (India Standard Time)
Service version:13.0.11109.177
Client version:1910.2.021
Cluster URI:https://wabi-north-europe-redirect.analysis.windows.net/

 

 

20 REPLIES 20
MYOMYO15
Regular Visitor

I have also the same issue like you. Did you fixed it.

metayeer
New Member

Hello everyone,

I've been looking for the same issue since yesterday and then I found my answer on this page : Credentials provided for the Web source are invalid - PowerBI - SharePoint Views

Hope this is gonna help some of you 😉 

AndyJazz
Frequent Visitor

Also facing the same issue would love to know if it was resolved and how.

lnadalon
New Member

I'm also having the same problem. I have several pbix using connection to sharepoint files, but only a few pbix gave this problem. I identified that the problem occurs when columns are merged between the sharepoint file with another source.
Unfortunately I didn't find a solution to work around this problem. The only solution was to undo the merge.

lnadalon
New Member

Hi everyone!
I'm also having the same problem. I have several pbix using connection to sharepoint files, but only a few pbix gave this problem. I identified that the problem occurs when columns are merged between the sharepoint file with another source.
Unfortunately I didn't find a solution to work around this problem. The only solution was to undo the merge.
lnadalon
New Member

Hi, was the issue resolved? I am facing the same issue.

In desktop the credentials works fine but online shows the same error. 

Anonymous
Not applicable

Hi @jishadshajahan, late to the party, but I came across this thread when I recieved the same error and think I have a solution.

 

After a lot of messing around, I tried out the whole process on my work Desktop computer, rather than laptop. THe only change that I could percieve between the two is that the Desktop is connected to some kind of Ethernet Network, whereas the laptop was on a different WIFI Network that works for all other access/permissions for work. For whatever reason, I think that moving to the Desktop may have allowed me to slip through a firewall that my company has set up and let me make the changes. It's super strange as I haven't had any issue like that before now, but it's what worked for me. Perhaps changing WIFI or using a VPN may solve this issue for you?

 

Hopefully this is helpful, maybe you already managed to solve it another way, which would be good to hear about.

venal
Memorable Member
Memorable Member

@jishadshajahan 

Please refer the link.

 

Use the same credentials and privacy level like in Power BI Desktop and Service.

 

If the issue is persists, please share the error message.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more

If this post was helpful may I ask you to mark it as solution and give it some kudos?

hi i recently encounter this error too.may i know how can i fix that. it says my credential are invalid but then" you're already signed in" at the below too

sign in error.PNG

Troubleshoot mapped network drives that connect to SharePoint Online 

In my case, password change from yesterday caused the issue.  Thought things would rejig overnight after logoff and reboot.  OneDrive needed signon today.  Still the error but after a several hours it sorted itself out.  I do not have admin rights so patience is needed.  Also just doing the refreshes may have helped to kick things along.

Hi there

What if you had to change the Authentication Method from Basic to Organizational?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hi ,

I didn't make any change, I always use authentication method as Organisational.

Can you confirm that the credentials you are using has got the required access?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Yes and it is working fine with the desktop version.

It does appear to be an issue with the Data Source Credentials




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

GilbertQ
Super User
Super User

Hi there

If you go into settings, then datasets and click on your dataset, can you click on Data Source Credentials and add your credentials there?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hi GilbertQ,

 

Thanks for your reply.

 

I tried the same but it is showing the same error, please find the below screenshot.

 

 und.png

Hi @jishadshajahan Did you solve this?  I have the same problem.  Two years later. 

Paul

 

Hi, was the issue resolved? I am facing the same issue. Please help.

Has this been resolved by anyone? The credentails are correct. They work perfectly fine for desktop but are not verifying in the app services.

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Dev Camp Session 26

Check it Out!

Mark your calendars and join us on Thursday, September 29 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors
Top Kudoed Authors