cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
smeadows
Regular Visitor

Data Gateway not found

In my Pro version of Power BI Service, I've installed a data gateway, but it is not showing on my Manage Gateways page. I've confirmed the on-premise gateway service is running, and tested the connection in the Gateway Configurator, but I can't find/use it. Trying to re-download the gateway fails, saying it looks like I'm trying to reinstall and must uninstall the current version first. Any ideas as to why it's not being recognized or found? (Tried on Chrome, Edge, and IE, all with no luck)

5 REPLIES 5
v-juanli-msft
Community Support
Community Support

Hi @smeadows 

In Power BI service, Manage Gateways is used for managing on-premise data gateway instead of on-premise data gateway (personal mode).

If you have installed the on-premise data gateway (personal mode), so when you go to the dataset settings, if this dataset requires gateway, you will see on-premise data gateway (personal mode) is available. 

 

Please check whether your gateway is on-premise data gateway or on-premise data gateway (personal mode).

There are several ways to check:

when installing the gateway, 

gateway-type.png

After the gateway installed,

q2.PNG

 

Check the dataset setting, in the picture below, it uses a personal gateway.

2017-09-15 09_29_18-Power BI.png

 

Best Regards

Maggie

 

Community Support Team _ Maggie Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-juanli-msft
Community Support
Community Support

Hi @smeadows

you did use the same account to log in Power BI Service and install the gateway, right?

 

Did you click on "Manage gateways" in "My workspace" but not see the gateway (lijuan's gateway" as mine?

3.png

 

Best Regrads

Maggie

Hi @v-juanli-msft

 

Yes, I used the same account for both, and when I click on "Manage gateways", nothing shows up. The Gateway Configurator shows in Status that the gateway is online and ready to be used; in Network that the status is Connected; in Diagnostics that the network ports test is Completed (Succeeded). When I've tried redownloading the gateway, I get the bottom image.

 

 

Capture.PNGCapture2.PNG

Greg_Deckler
Super User
Super User

Did you install Personal or Enterprise. If Personal, are you logged in with the same account in the Service that you installed/registered it? If Enterprise, same question or have you given the user access to use the gateway?


@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
Mastering Power BI 2nd Edition

DAX is easy, CALCULATE makes DAX hard...

I installed Enterprise, and I am logged in with the same account used to install it.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.

Top Solution Authors
Top Kudoed Authors