cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Angel
Resolver III
Resolver III

Can´t link datasource to gateway (new gateway experience)

Hi everyone,

 

I wish someone can help me. I have struggled for days with a problem I don't know how to solve it.

 

When I am trying to link a datasource with a a gateway that it's working, the apply button is grey and I can't click on it.

 

Does anyone has the same issue?

 

Thanks in advance,

ScreenShot.JPG

1 ACCEPTED SOLUTION
Angel
Resolver III
Resolver III

Hi @v-luwang-msft ,

 

Finally, the problem was the PBI desktop version when the report was created. It was too old (December 2019).

 

To solve this issue, I open the PBI report with a more newer version and publish it. After doing that, everything was ok..

 

Thanks anyway

 

 

View solution in original post

2 REPLIES 2
Angel
Resolver III
Resolver III

Hi @v-luwang-msft ,

 

Finally, the problem was the PBI desktop version when the report was created. It was too old (December 2019).

 

To solve this issue, I open the PBI report with a more newer version and publish it. After doing that, everything was ok..

 

Thanks anyway

 

 

v-luwang-msft
Community Support
Community Support

Hi @Angel ,

To get it to work, make sure all of your connections are removed from your Gateway (under GATEWAY CLUSTERS). Note there is nothing under your GATEWAY CLUSTERS.

vluwangmsft_0-1654238876891.jpeg

 

Click the blue box with the link that says 'Add data sources to use the gateway'. Create an initial datasoure but do not call it what you want to call it. For now, just call it 'Garbage' but use actual credentials to access your data source. You want it to say 'Connection Successful' after you apply your settings.

vluwangmsft_1-1654238876896.jpeg

 

Now go to your dataset and click the schedule refresh button and expand Gateway connection. Click use a data gateway and it will say not configured correctly as the status. Under actions, click the traiangle pointing to the right. Click Add to gateway. Readd the data source, this time with the name you want and the same credentials. Go back to your Gateway connection and it should now be green.

vluwangmsft_2-1654238876899.jpeg

 

 

You will want to hit apply to get the data source credentials corrected. You can now remove 'Garbage' by hovering over the data source under GATEWAY CLUSTERS (make sure you hover on the right side of the grey block), click the ellipse that appears and then remove.

 

To learn more details ,refer:

https://community.powerbi.com/t5/Service/gateway-quot-not-configured-correctly-quot/td-p/475932 

 

Did I answer your question? Mark my post as a solution!


Best Regards

Lucien

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.

Top Solution Authors
Top Kudoed Authors