cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mumair
Helper I
Helper I

Slicers not affecting certain tables?

I am trying to create a dashboard, and I am using slicers to manipulate the data. However, there is one table that my slicers won't affect. This is confusing me because all of my tables are either directly or indirectly linked. The table that is not affected was a created table, so I am wondering if this would have any effect?

6 REPLIES 6
MarvelousMar
New Member

I had come across the same issue. What I did was selecting the slicer in question go to the top tabs in 'Format' > Click on 'Edit interactions' > You'll be able to see which tables are or are not affected. There will be two images, "Filter" & "None," appearing for all the tables/selections you have in your dashboard. That should solve your problem. You can exist out by clicking 'Edit interactions' afterward. 

CahabaData
Memorable Member
Memorable Member

let's clarify; we're in Desktop forum so we're discussing a report - rather than a dashboard I will presume since dashboards are in Service.

 

You have a slicer on the same page as another visual - and when selecting values in the slicer, the visual is not changing?  that is my interpretation of your post.

 

I would delete the slicer, and re-add it as a quick sanity check; but assuming the behavior is the same it means the data set in the visual is not being affected by the filtering of the slicer even though you say the tables are related.  A guess is the impact/result of another table's join is the reason. 

 

Rather than use a separate table for the slicer content - can you use the field of the dataset in the visual directly as your slicer source.  Sometimes this is possible depending on the data structure.

 

Another thing you could do is make a copy of your pbix - and delete the joins of those other tables and experiment that way.  This would free up the impact and verify that it works in a simpler set up.  Not the final answer of course but possibly the path to understanding.

www.CahabaData.com

Correct, I am using Power BI Desktop to create a report. I only called it a dashboard because I am trying to display key performance metrics.

 

Deleted the slicers and readded them and they still do not work.

 

Can't use the field in the visual as the slicer because of the data structure.

 

The bidirectional filter is also turned on.

 

Any other ideas or thoughts?

I have had slicers not perform as I expected - not due to a bug, but because the joins between tables can affect the definition of the data set.  So as noted in the last paragraph of my first post; what I would do at this point is make a copy of your pbix - and delete the joins of those other tables and experiment that way.  This would free up the impact and verify that it works in a simpler set up.  Not the final answer of course but possibly the path to understanding.

www.CahabaData.com

Do the nonfunctioning slicers rely on an inactive relationship?  If so, see if changing that relationship to Active solves the problem.  If this is not the problem, then there is likely something wrong with your data model or underlying data.  Please share your pbix file (scrubbed for any sensitive data) if you want.

Also make sure you have bidirectional cross filter turned on as it may be an issue with how the filter flows.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.