Showing results for 
Search instead for 
Did you mean: 

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.


Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!


- The Power BI Modeling Team

476 REPLIES 476

this is a known issue and we're investigating a fix.

Jeroen — this is the main issue blocking our use of this feature in production. We have MANY datasets and analysts want to add their own lists but build permission is not an option. 

This is a known issue, please upvote this idea to help prioritize it:

Microsoft Idea  · Directquery for datasets only needs read permissions on all datasets (


Frequent Visitor

Hi MLechner, 


We have the same behaviour and to my knowledge there isn't another way around it at the moment, which is frustrating...

Regular Visitor

This is a great feature, when using/testing it I run into the following problem though.


- I connect to an Azure Analysis Services tabular model

- Then I add a calculated column to a fact table using RELATED to add a value from a dimension table within the same model which has a one to many relationship with the fact table, no errors appear when doing this

- As soon as I try to use the calculated column (or something using it) in a visual this error appears:




- The strange thing is that this does work when doing the same thing but with a different dimension from the model (no error appears when using it)


What can cause this error? As far as I can tell I'm not doing something that isn't supported and as I'm referring to a table within the same model I don't see any issues (no limited relationship).


One thing that is different between the dimension for which this works and the one for which it doesn't: the key in the fact table which relates to the dimension which doesn't work has blank values as the dimension isn't applicable for all the rows. In this case I expect RELATED to return a blank value. Also I'm pretty sure this worked when I tested it earlier in the year.


Hopefully you can help me with this, thanks in advance!

we were unable to reproduce this - can you please open an issue for this so we can collect some more info?

Sure, do you mean I should post it on Issues - Microsoft Power BI Community or should I open a support ticket?

either works - but support ticket is faster.

hmm, interesting, let me talk to the engineers. Thanks for reporting!

Frequent Visitor

This is mega!

Do we have a view when the next version of SQL Server will be released brining this feature online for tabular SSAS users?

Working on the Product Team for PowerBI must be the coolest job in Microsoft.

it is pretty cool, thanks 🙂 regarding the next version of SQL - not sure, but looking at the speed of previous releases I'd say 2022/2023.

Frequent Visitor

To be blunt, the lack of conformed dimension support, the errors, the bugs, the poor performance on all but tiny datasets... This feature is useless to enterprise customers. 


Please prioritise quality over speed to market.

Josh Ash


thanks for the feedback - it would be great if you can give specific examples of where you are seeing perf issues, errors, bugs and on which version of Desktop. We have worked on improving performance specifically in the last couple releases of Desktop and our telemetry shows that those improvements are paying off. Curious to learn what you think we need to do as well. Also, not sure what you mean that we don't support conformed dimensions. We are working on a best practices document that explains how to deal with the most common issues people have with this feature.

Helper II
Helper II

Has there been any further thoughts around the end user permissions that are required in order to view a published report that has been crafted from a shared dataset under the Direct Query / Local Model? 


Having to add a report end user / consumer to the primary shared dataset with Build permissions is an issue. We have analysts that we restrict to shared datasets and in turn they share out their reports to end users. Having the analyst grant users access to the report they created and then turning to the admins to have the end users granted Build permission to the shared dataset is a security issue. These end users could then connect to the core shared dataset and access data they should not be able to view.  

Frequent Visitor

I brought this up a while ago. Is it being addressed? If so when will it be fixed? 

I haven't heard that it's been addressed, but I recommend voting on this idea here:

Microsoft Idea  · Directquery for datasets only needs read permissions on all datasets (


I can confirm it has not been addressed but will be before we declare this generally available.

Any idea when it will be declared generally available?  I can't see it on the roadmap.  We don't allow build permissions so until we can use this with read only access, we can't use it.

Frequent Visitor



We have a dataset that is combing two datasets from separate workspaces. When we renamed one of the workspaces the composite dataset failed, as the connection seemed to be referencing the workspace names, as opposed to the workspace ids. Is this behavious likely to be addressed?


Many Thanks!

the reference by workspace name is actually by design for technical reasons. We will publish a best practices doc that lists this as well as other things. Sorry for the inconvience.

I have a model + thin report and need to rename tables from data source, but this breaks the thin report.

How can I update table names referenced in the report?

Helpful resources

September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show episode 9

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors