cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
c4rlosmarin
Frequent Visitor

Microsoft Mashup Evaluation Container is killing my box (PowerBI Desktop = CPU + Memory Hog)

Just so you know, the following is still happening:

http://community.powerbi.com/t5/Desktop/PowerBI-Desktop-CPU-Memory-Hog/m-p/13942/highlight/true

 

And the following workaround did not fixed the issue:

https://social.technet.microsoft.com/Forums/en-US/63159ce7-1252-49ea-891f-d01d7fd4e1be/microsoft-mas...

 

I'm currently using the latest Power Bi Desktop version. My issue is mainly related to querying a 800MB+ XML file, just opening the file, no transformation or any other additional task.

1 ACCEPTED SOLUTION
v-yuezhe-msft
Microsoft
Microsoft

Hi @c4rlosmarin,

Multiple calculations(complex measures and calculated columns) in large dataset will eat up much CPU and memory . In your scenario, there are some proposals for you troubleshooting such performance issue.

1. Use the latest version of Power BI Desktop(2.42.4611.901).

2. Untick the following options in your current PBIX file. You can go to File -> Options and settings -> Options->CURRENT FILE(Data Load) to find the options.
1.PNG

3. Follow the guide in this blog to disable Load for these intermediate queries in your PBIX file to save memory.

4. Optimize your data model by following  the tips in the articles below.
  Data Import Best Practices in Power BI
  Power BI Performance Tips and Techniques

5. Use a faster computer with bigger memory would help in your scenario.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
anandam2000
Microsoft
Microsoft

Memory hog caused by multi instances (300+) of Microsoft mashup Evaluation Container.NetFX45 

 

Since last 2 weeks my sql server has specific issue, where it will start adding 20 - 50 instance of Microsoft mashup Evaluation Container.NetFX45, each holding ~30MB of memory (not a big deal), but multiply it with # of instances it is adding everyday, within a week, i run out of the memory and server is almost dead.

I have PowerBI OnPrem Gateway setup on the server, restarting the gateway resolves it by removing all instances of Mashup container, and again starts adding 20-50 instances each day.

 

There are ~20 of pbix which are setup to refresh daily using powerbi gateway, and other users who may be running other reports.  I have removed the above mentioned recommended settings from hosted powerBI reports, and also removed these settings from gateway settings to turn off Query Caching.

 

Still new process gets generated, and memory is blocked... any pointers what else could be causing it and remediation for it.

hourir2
Frequent Visitor

@v-yuezhe-msft  Thank you!!! I just unticked the first option and it fixed my slowness issue! FYI, I kept the parallel loading of tables ticked as I think it is 1. Useful and 2. Shouldnt slow down general running of your Power BI.
thanks again

v-yuezhe-msft
Microsoft
Microsoft

Hi @c4rlosmarin,

Multiple calculations(complex measures and calculated columns) in large dataset will eat up much CPU and memory . In your scenario, there are some proposals for you troubleshooting such performance issue.

1. Use the latest version of Power BI Desktop(2.42.4611.901).

2. Untick the following options in your current PBIX file. You can go to File -> Options and settings -> Options->CURRENT FILE(Data Load) to find the options.
1.PNG

3. Follow the guide in this blog to disable Load for these intermediate queries in your PBIX file to save memory.

4. Optimize your data model by following  the tips in the articles below.
  Data Import Best Practices in Power BI
  Power BI Performance Tips and Techniques

5. Use a faster computer with bigger memory would help in your scenario.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-yuezhe-msft though this fixed the issue however i am wondering what do these 2 options do and does it affect the model in any way ?

 

do we have to check these options back before we upload the data back on Service ?

A larger machine isn't necessarily the solution, its apparent there is a Memory leak in the service and it is exacerbated on systems with the enterprise gateway. We a have a machine with 24GB of memory and the run away memory leak flattened it. The work around was restarting the gateway but that is hardly a good solution. 

A larger machine isn't necessarily the solution, its apparent there is a Memory leak in the service and it is exacerbated on systems with the enterprise gateway. We a have a machine with 24GB of memory and the run away memory leak flattened it. The work around was restarting the gateway but that is hardly a good solution. 

@v-yuezhe-msft: thanks! for some reason I was not getting the notification regarding the availability of a newer version of PowerBi Desktop, I had to manually download it. After that, disabling Background Data and Parallel Loading of Tables fixed the issue.

Proposal 2 seems to have fixed the issue for me.  Hard to change these options while your pc is grinding to a halt though!

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors