Showing results for 
Search instead for 
Did you mean: 
Frequent Visitor

How do I show my value as a percentage in a visual?

Hi All,


I have a set of data in Excel already formatted as percentages (2 decimal point) which sums to 100%, see table below.


 Age profile - 2015 to present (%)Age profile - 2005 to 2014 (%)Age profile - 1995 to 2004 (%)Age profile - 1985 to 1994 (%)Age profile - 1975 to 1984 (%)Age profile - 1965 to 1974 (%)Age profile - 1955 to 1964 (%)Age profile - 1948 to 1954 (%)Age profile - pre 1948 (%)


In my query editor on Power BI, the figures are shown as below.




and when I create a stacked bar visualisation, the percentages are not represented but only as a decimal.




How can I show these values as a percentage out of 100%, including on the axis. I have tried changing the data type in the query editor but still to no success.


Help would be appreciated.





Not applicable

Try set the measure as Type: Decimal, SubType: Percentage



View solution in original post

Frequent Visitor

Hello everyone


Does this work with Power BI Desktop version?


I have October Update version of Power BI Desktop. I am trying display values as percentage in a bar chart. But somehow "Formatting" section under Modeling is grayed out to me.


I am getting data from a SQL server Analysis server (I dont know if it matters)


Please help me. Thanks in advance



Did you select column before viewing the Modeling section. Without selecting any column from the fields section, formatting will be grayed out.

Thanks for responding. 


Yes I selected the bar chart which I want to change from values to percentage. Also I tried by changing to table or other visuals if Formatting will be available. But no luck


It's not about selecting the visuals.


Select a column and then check with modeling. 

You can see in the image, I selected BudgetMSPricing and gives me Formatting options.

Its strange. I have tried selecting column as well. But no luck.


Its strange. Formatting is always grayed out irrespective of which column I selected or which Visual I selected


Thanks for responding


Try closing you file and re-open. can you share your file..?

Thanks a lot friend. You saved my effort.

Infact It was neither getting activated for me as well. Because I was just clicking on the fields to get it selected.

But your picture made it easy. I understood I was not selecting the field but just clicking it.


This saved my half day's effort.

Looking forward to more of your useful tips.

Thanks Again

Not applicable

Try set the measure as Type: Decimal, SubType: Percentage



View solution in original post

Frequent Visitor

Thanks Cabelo!

Helpful resources

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors