cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sasa Frequent Visitor
Frequent Visitor

Export to csv place all data in one column

On my home PC whenever i export data from Power BI Desktop to csv. it place data in separate columns in csv file.

But i have problem on my work PC where all data is exported in one column where data are separated by coma.

How to overcome this problem so my work PC export data same as my home PC.

Both PCs work with original setting which came with instalation. 

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-yuezhe-msft
Moderator

Re: Export to csv place all data in one column

@Sasa,

I am not able to reproduce your issue, you export from same visual on both home PC and work PC, right? If so, the issue is related to the settings on your work PC, have you checked the region settings on the work PC?

On you work PC, please publish PBIX file to Power BI Service, then export data from visual to Excel file. And if you need CSV file, save the Excel file as CSV file and check if the issue still occurs.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
2 REPLIES 2
Moderator v-yuezhe-msft
Moderator

Re: Export to csv place all data in one column

@Sasa,

I am not able to reproduce your issue, you export from same visual on both home PC and work PC, right? If so, the issue is related to the settings on your work PC, have you checked the region settings on the work PC?

On you work PC, please publish PBIX file to Power BI Service, then export data from visual to Excel file. And if you need CSV file, save the Excel file as CSV file and check if the issue still occurs.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Sasa Frequent Visitor
Frequent Visitor

Re: Export to csv place all data in one column

Ty Lydia.

Problem solved. On my work PC i publish file, and then i can export it to xlsx where it is stored properly. Didnt realize that before so i exported data directly from PBI Desktop ( than only option is csv).

I bealive that checking regional settings will fix issue about placing all data in one column.