Showing results for 
Search instead for 
Did you mean: 
Helper II
Helper II

Bug Can't Apply Changes and Save Report

I recently downloaded the most recent version of PBI Desktop from the advanced downloads online. I have an issue now that after adding three new datasources (all MS SQL DBs tables) I can't apply the changes from power query editor. I click apply changes and it evaluates but then just closes the loading page and does not actually add anything to the model. I have tried closing power bi and restarting computer same issue. Tried reinstalling with the repair. Same issue. It doesn't fail and it loads fine in PQE. If I click the close button on the top right, it says I have changes do you want to apply. If I click apply and save it does the same thing. Anyone having this issue too? This is what I see when it runs. 



Frequent Visitor

Apparently, it's a known bug that's being investigated.



Community Support
Community Support

Hi @JaromBIDEVatDK ,


Did you solve your problem? Did the clear cache mentioned by @lbendlin help you?


If you click the refresh button, does the data load properly into the model?

Are there any error messages reported in the Power Query Editor?


Best Regards,

Super User
Super User

Have you tried clearing the cache in the options dialog?

Helpful resources

Vote for T-Shirt Design

Power BI T-Shirt Design Challenge 2023

Vote for your favorite t-shirt design now through March 28.

March 2023 Update3

Power BI March 2023 Update

Find out more about the March 2023 update.

March Events 2023A

March 2023 Events

Find out more about the online and in person events happening in March!

Top Solution Authors