cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Administrator
Administrator

El uso de un valor estático en una medida rompe los filtros visuales

Tengo un objeto visual de tabla filtrado por segmentaciones de datos y filtros de informe. He creado una serie de medidas que evalúan cada fila dentro de esa tabla de datos haciendo referencia a un valor dentro de esa tabla. Cuando intento aplicar un valor estático a una nueva medida, los filtros de tabla se omiten y aparecen todos los valores.

Por ejemplo, tengo una tabla de datos con cuentas filtradas por una segmentación de datos que indica un territorio de ventas. Un ejemplo de una medida sería un recuento de pedidos para esos clientes de una tabla relacionada. Cuando intento aplicar cualquier valor estático o lógica, los filtros de la tabla se rompen. Por ejemplo, si creo una medida que dice IF([OrderCount]>1,"Active,"Inactive") entonces todos los valores de la tabla de cliente ahora aparecen en el objeto visual.

¿Qué estoy haciendo mal aquí?

1 ACCEPTED SOLUTION

Gracias @parry2k que funcionó. Aunque no estoy seguro de entender por qué. Tengo el mismo problema al aplicar incluso cálculos simples, es decir, si quería simplemente restar un valor de [OrderCount] ocurre lo mismo. Entonces, ¿tendría que agregar una declaración IF como esa para evaluar si no está en blanco? Creo que ahí es donde me tropiezo.

View solution in original post

3 REPLIES 3
Administrator
Administrator

@WiggityZwiggity Me alegro, funcionó. Aunque no importa creo que por error su aceptó su respuesta como una solución.

Consulta mi última entrada de blog Comparar escenarios presupuestados con frente a datos reales Me gustaría elogios si mi solución ayudara. 👉 Si puedes dedicar tiempo a publicar la pregunta, también puedes hacer esfuerzos para dar Felicitaciones a quien haya ayudado a resolver tu problema. ¡Es una muestra de agradecimiento!

Visítenos en https://perytus.com, su ventanilla única para proyectos/formación/consulta relacionadas con Power BI.

Administrator
Administrator

@WiggityZwiggity porque ahora está devolviendo el valor en esta nueva medida, inténtelo así

IF([OrderCount]>1,"Active,IF (NOT (ISBLANK([OrderCount]),"Inactive")) 

Gracias @parry2k que funcionó. Aunque no estoy seguro de entender por qué. Tengo el mismo problema al aplicar incluso cálculos simples, es decir, si quería simplemente restar un valor de [OrderCount] ocurre lo mismo. Entonces, ¿tendría que agregar una declaración IF como esa para evaluar si no está en blanco? Creo que ahí es donde me tropiezo.

View solution in original post

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.