cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
IncursioML1
Frequent Visitor

visual not loading

What could be causing this error below?  The report loads fine in the desktop but then something doesn't work with the visuals in the cloud.  I have to delete the dataset in cloud and then publish back every single time in order for it to work.

Is there something that's not loading properly on the calculated table?

IncursioML1_0-1630350421693.png

 

4 REPLIES 4
GilbertQ
Super User
Super User

Hi @IncursioML1 

 

Can you refresh the dataset and see what happens if it still fails after the refresh. The error appears that the calculated table is not in a processed state?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Ah yes, it does seem that it is failing on the refresh state.

The gateway is running on a physical machine that's on 24/7, in which I have 2 connections in the report.

The first is a SQL query to an on premise database, which appears to work with the connections.

The second one is a SharePoint Online list in which I had set it to OAuth type.

My guess is that it's the SharePoint one since a couple of those queries does some relationship mapping to the SharePoint Online List that gets brought in.  What is the correct way to set up a SP Online refresh?  Can this not be done on a On Premise gateway?

Hi @IncursioML1 

 

I would suggest creating a data source in the On-Premise gateway to your SP Online list, and then you can select it in the Gateway and it will all be refreshed together?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Yes this works when I push it using desktop and that on-prem gateway that uses SP Online List and also SQL Server On Prem through that gateway.

The problem seems to be literally only when the schedule refresh occurs in Power BI Cloud or if I manually refresh in the Cloud version.

There seems to be something happening on one or two of the tables in which there is a relationship and there are some LOOKUPVALUE DAX expressions that are used in the SharePoint Online dataset to the SQL Direct Query dataset.  

However, if I refresh the data on the Desktop it works fine, but anything on the cloud, manually or scheduled the dataset refreshes with no errors, but the visual won't load.  I don't want to have to manually refresh on the desktop and push to cloud to fix that problem.  I'll take a browse again to make sure maybe one of the DAX calculation is working with all the records from SharePoint.  I assume they did because of no errors on the desktop pbix file.

 

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!