cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emveha
Resolver II
Resolver II

the on-premises data gateway's service account failed to impersonate the user

hi

yesterday i  installed the new on-premises data gateway and i restarted it as it is recommended. In the status overview tab i can see that the gateway is online and ready to be used. Unfortunately, all my scheduled jobs failed due to "the on-premises data gateway's service account failed to impersonate the user". By default the NT SERVICE\PBIEgwService is the account that manages the gateway and i never had to change this, could this be causing my scheduled jobs to fail or is there an other issue???

hope you can help

thanks
M

5 REPLIES 5
agarwal137
Frequent Visitor

Faced same issue on migrating to a new laptop. The SQL datasources were not connecting on Power BI Service resulting in failed reports refresh. However, files on sharepoint could connect and refresh. The error thrown was -

agarwal137_0-1642582293694.png

 

After 2 days of trying everything, it somehow got solved. Here's how - 

 

- Ensured .NET is installed on system

- Installed Microsoft Access Database engine 2010

- Installed MS ODBC driver 17 for SQL server

- Uninstalled and reinstalled On Premises data Gateway.

- Did a reset of Domain/Laptop Login Password

- Selected the 'existing gateway' for setup (which was being used earlier to run reports in old laptop)

- After setup, logged into Gateway using domain email id.

- Ran couple of reports on Excel connected to the same SQL server databases

- Then Closed everything and did a system shut down.

- Restarted system and found that the datasources were back up on Power BI servcie!

 

Note that I checked the data source connection status after each step and it wasn't up until the last. So not sure if all are relevant but then here's how it got solved for me.

 

(have posted this on similar query too. Sorry I couldnt find how to link)

emveha
Resolver II
Resolver II

while checking the error logs i noticed that the password of this account has expired....

System.ComponentsModel. Win32Exception (0x80004005)

Any idea how to solve that???

Hi @emveha ,

 

Try the following steps:

 

For the delegation settings on the gateway service account,Check 'Trust this user for delegation to specified services only' And not 'Use Kerberos only' but 'Use any authentication protocol'.

 

Best Regards,
Kelly
 
Did I answer your question? Mark my post as a solution!

Hi,

 

Where can I find these delegation settings? Currently my Power BI Gateway is still running under SERVICE\PBIEgwService. But I'm getting the same error as described above. People point me to this solution, but I cannot seem to find these deleagtion settings.

 

thank you in advance.

Jelle

@jelledaemsmy advise is to create a microsoft ticket for this issue: https://powerbi.microsoft.com/nl-nl/support/pro/

in my case it was the only way to get this issue solved.

Good luck!

M

Helpful resources

Announcements
August 2022 update 768x460.jpg

Check it Out!

Click here to learn more about the August 2022 updates!

Power BI Dev Camp Session 25 with aka link 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, August 25 at 11a PDT for a great session with Ted Pattison!

August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors