cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
trinathreddy
Frequent Visitor

"Share" option is missing in the reports in PBI service

Hello,

 

Is anyone experiencing the PBI "Share" option missing in the PBI service. I used to share my reports previously and Now I cant find that button anymore. 

I either open the report to share it with specific users using the Button on the report ribbon. Now I cant find it. Below are the palces where I used to find them.

2.PNG--This is in OVerview1.PNG

 
2 ACCEPTED SOLUTIONS

@v-diye-msft 

 

 

 

 

 

 

 

 

 

View solution in original post

Hi trinathreddy,

 

OK got the issue, in this case, delete the whole history for the browser from the start and do not sync your history to your browser again, then log in and see if it works on your browser.

View solution in original post

13 REPLIES 13
ARCEOADAME1209
Regular Visitor

Thank you for sharing the solution!! Also driving us crazy this... 🙂

Mrab
Helper I
Helper I

Did you get a solution for this one? if yes, can you please share.

v-diye-msft
Community Support
Community Support

Hi @Mrab 

 

Please confirm below questions: 

1. Please make sure you are the pro user. (Free user can't use the peer-to-peer option)

2. You are the owner/creator of the report. (If not, the owner can limit the reshare permission of the report)

 

 

Community Support Team _ Dina Ye
If this post helps, then please consider Accept it as the solution to help the other members find it more
quickly.

@v-diye-msft 

 

 

 

 

 

 

 

 

 

venal
Memorable Member
Memorable Member

@Mrab @trinathreddy 

Have you tried to check the setting in "Admin Portal".

 

Settings >> Admin Portal >> Tenant Settings >> Export and Sharing Settings >> Share Content with external users.

Sharing Option in Admin Portal.JPG

 

If this post helps, then please consider Accept it as the solution to help the other members find it more
If this post was helpful may I ask you to mark it as solution and click on thumb symbol?

 

BR

venal.

Hi @venal , @v-diye-msft ,

 

I have pro licence and developed over 60 reports to various groups. I and it is enabled in Admin portal. I can see them in other browsers too. I cleared my cache, changed password and tried to delete cookies manually in the chrome browser. "Share Option" is still missing. 

It works in other browsers !!! But wont work if PBI was used on that earlier!!

I guess microsoft has to do somethign with their updates. Its an issue where the some of the latest updates wont relfect when the browser is not reset completely. In my case, I cant do that as I have some info saved in the browsr and cant afford to lose it all. 

 

Miscrosft has to look into it and resolve this at the earliet. 

 

 

Hello trinathreddy,

 

Did you try another browser or someone else's computer to log in and see if the share option is still missing? Try that, and reply, so we know what the problem is.

HI @Mrab ,

I Just tried EDGE browser. It works on any other browser in my PC. It only dont show up, if the PBI was already used on that particular browser before they rolled out the new updates that includes  "Share" option next to the report name. 

Hi trinathreddy,

 

OK got the issue, in this case, delete the whole history for the browser from the start and do not sync your history to your browser again, then log in and see if it works on your browser.

I had this problem too and found a much easier solution: 
Disable ad blocking software (i.e., whitelist app.powerbi.com)

 

In Chrome, it was the Adblock Plus extension that caused the problem for me and in Edge, it was the Adblock exentension. 

In both cases, I suspect it was the social media blocking options (i.e., "Block social media icons tracking" in Adblock Plus and "Antisocial filter list" in Adblock) that hid the "Share" button, though I did not test it further.

v-diye-msft
Community Support
Community Support

Hi @trinathreddy 

 

Do you have the pro license or an overdue pro trial? If there no RLS applied, please kindly make sure you're the pro user or the report is located in the premium workspace. 

 

Community Support Team _ Dina Ye
If this post helps, then please consider Accept it as the solution to help the other members find it more
quickly.
v-diye-msft
Community Support
Community Support

Hi @trinathreddy 

 

Please kindly make sure there no RLS applied in your report. 

 

Community Support Team _ Dina Ye
If this post helps, then please consider Accept it as the solution to help the other members find it more
quickly.

Hello,

 

I am having the same problem. There is no row-level security applied to the report. 

 

IS there any other way we can get that option back?

 

Thanks,

 

#Mrab.

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors