cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jordi
Advocate I
Advocate I

publish to web won't refresh

For a newly made report I used the "publish to web" function.

The first days it seemed to work well, but now the report won't refresh, so the 2-hourly update wont show in the webpage.

 

I know there can be a one hour delay, but even than there is no refresh.

Only when I refresh the html page (F5) the reports also update.

 

For example:

The report on the html page has the last refresh date/time:

 

Last refresh in the html page

 

The powerBI report itself has been refreshed at 16.03hrs

Last refresh powerbi

 

And at this moment (17.30hrs) the report still hasn't been refreshed.


There haven't been any changes on the website-side. I tried to republish (to web) the reports, used the newly generated iframe code, but still nothing.

 

Any ideas?

1 ACCEPTED SOLUTION

I've got response from the Product Team.

The behavior is by design. The users can use an URL parameter refresh with reload interval specified in minutes, e.g.: https://app.powerbi.com/view?r=<embedcode>&refresh=5

Strange, I can't recall that I read anything about this function, but hey, going to give it a try 🙂

View solution in original post

13 REPLIES 13
hfleitas
Frequent Visitor

I couldnt find the exact refresh counter to pass as the parameter.

Ended up deleting the report and dataset from my workspace, then republished from pbi desktop and recreated the Publish to Web with a new embedded code. Not ideal given there's a refresh paramater but it worked.

v-caliao-msft
Microsoft
Microsoft

Hi @Jordi,

 

Does this issue occur on this report? Or for all of you report?

 

Regards,

Charlie Liao

This is the only report we've published to web, so for now it oinly happens to this report.

Correction: I've saved the report (In Desktop) as a copy and published that one Web, but the same problem.

Report itself is refreshing fine but the embedded report won't refresh.

Got reply from PowerBi/MS:

 

I can repro the same issue as you. I’ve reported it internally to Power BI Team: CRI 33615073
I’ll post here once I get any update about it.

 

That's good, hopefully they will fix it soon.

I've got response from the Product Team.

The behavior is by design. The users can use an URL parameter refresh with reload interval specified in minutes, e.g.: https://app.powerbi.com/view?r=<embedcode>&refresh=5

Strange, I can't recall that I read anything about this function, but hey, going to give it a try 🙂

n8barber
Frequent Visitor

THANK YOU! It was really frustrating to publish to the web and have it show wrong data. This fixed it for me!

Anonymous
Not applicable

Where do I put the Refresh? I have tried multiple location in the embed code and can not get his to work?

 

 

Todd,

 

Try this, click the Gear icon on the top right, then Manage embed codes.

Select the embed code for the report you've published to web and add the corresponding counter as specified in the solution. If you have refreshed or updated the report multiple times then it would 2, 3, 4, etc that you can try.

 

https://app.powerbi.com/view?r=<embedcode>&refresh=5

 

ManageEmbedCodes.jpg

 

Hope that helps,

Hiram

Hi Folks,

 

I cant seem to get this working for me.

 

@hfleitas you seemed to me mentioning that the refresh=[value]

the value should be some value which is maybe a version of the updated report?

 

Do you know how to find such a version number I cant seem to find it within my embed codes.

Also from the original message from customer services it seems to say the value should be the refresh interval in minutes?

 

Thanks

Still the same problem.

More specific, the problem seems to be in the use of a slicer in the report.

Say value A is selected, and after a day still the data from previous day is shown. When I then select Value B I get to see the recent data from today. Then I select back Value A, and get to see the old data from yesterday again.

Last week I updated the report, adjested all the urls with the refresh paramater, and now my reports are nicely updating. Looks like problem solved (for me).

Hello Jordi,

I tried the same thing that you told. But, it is not working. The Published URL doesnot refresh. Any solutions?

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors