cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

on-premise data gateway sap bw

Hi all,

 

I'm having an issue setting up a schedle refresh for reports which have SAP BW database as a source.

 

We are using the new SAP BW connector (Implementation 2.0) and have installed the latest on-prem gateway (Sept 2018).

 

I'm getting the following error:

 

Last refresh failed: Tue Oct 02 2018 14:28:46 GMT+0100 (GMT Summer Time)
Cannot connect to the mashup data source. See error details for more information.Hide details
Underlying error code: -2147467259 Table: Site Master Data Base Query.
Underlying error message: We're sorry, an error occurred during evaluation.
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Cluster URI: WABI-NORTH-EUROPE-redirect.analysis.windows.net
Activity ID: 8364de43-1b34-4c8a-b089-80cd0e6217d0
Request ID: a9d6b52f-d3f3-4778-ab3f-cf843c95dbc4
Time: 2018-10-02 13:28:46Z

 

Has anyone else come across this?

 

Thanks

 

Mike

 

 

17 REPLIES 17
Anonymous
Not applicable

We are experiencing the same error message in one of our customer environments. 4 gateways running the same GW version, but for some reason only one of them works. We were running different Windows server versions, but we validated that did not seem to make a difference here. Gateway logs do not seem reveal any cause for the error either. Currently waiting to have a debugging session with the SAP team to see from their logs if the requests are visible and are they blocked due to the language parameter or some other reason. What we don't understand, that if it would be for the language parameter, why is it working with another server and not with the others (with same On-premises gateway version, March 2019). The one that is working is hosted in Azure (Windows Server 2016 Datacenter) and others in local data centers, but that shouldn't play any role here.

@Anonymous would be interested to hear how you get on, unfortunately defaulting the language didnt seem to resolve the error we were getting thanks Ed

Hi @EdEvetts 

 

Microsoft traced the error to the Gateway making a test connection before trying to make the live connection.  They resolved this in the April 2019 version of the Gateway which has added a tick box to "Skip Test Connection".

 

When I checked this box I was able to sucessfully set up the SAP BW datasource on the Gateway.

The scheduled refresh doesn't always work as the "Skip Test Connection" box doesn't seem to stay selected.

Thanks @HMJSomerset 

 

I saw the check box, I'll give that a go, why does that make it work?

 

thanks Ed

@HMJSomerset I did see the check box, but when I looked again today it seems to not be there, can you still see it?

 

thanks Ed

Hi @EdEvetts .

I looked this morning and the check box does not appear in the datasource in Manage Gateways.  However, when I clicked on "Test all connections" all reported successful.

 

I checked the Data Source credentials in Workspace/Datasource there is a warning "Some credentials aren't validated as they are set to skip test connection.".

I am now confused - I will check to see if an update is available for the Gateway.

v-shex-msft
Community Support
Community Support

Hi @Anonymous,

 

Can you please share some detail information about this to help us clarify your scenario? (r.g. local gateway log, refresh history, snapshots)

 

Spoiler

Tools for troubleshooting

Collecting logs from the gateway configurator

There are several logs you can collect for the gateway, and you should always start with the logs. The simplest way to collect logs after installing the gateway is through the user interface. In the On-premises data gateway user interface, select Diagnostics and then select the Export logs link near the bottom of the page, as shown in the following image.

On-prem-data-gateway-UI-logs

Installer logs

%localappdata%\Temp\On-premises_data_gateway_*.log

Configuration logs

%localappdata%\Microsoft\On-premises Data Gateway\GatewayConfigurator*.log

On-premises data gateway service logs

C:\Users\PBIEgwService\AppData\Local\Microsoft\On-premises Data Gateway\Gateway*.log

Event Logs

The On-premises data gateway service event logs are present under Application and Services Logs.

On-prem-data-gateway-event-logs

Fiddler Trace

Fiddler is a free tool from Telerik that monitors HTTP traffic. You can see the back and forth with the Power BI service from the client machine. This may show errors and other related information.

Refresh History

When using the gateway for a scheduled refresh, Refresh History can help you see what errors have occurred, as well as provide useful data if you need to create a support request. You can view both scheduled, as well as on-demand, refreshes. Here is how you can get to the Refresh History.

  1. In the Power BI navigation pane, in Datasets, select a dataset > Open Menu > Schedule Refresh.

  2. In Settings for... > Schedule Refresh, select Refresh History.

 

BTW, did this issue only appears on implementation 2.0 connector? Have you tested with previous one?

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Anonymous
Not applicable

Hi Xiaoxin,

 

The issue seems to have started when we started using the Implemtntation 2.0.

 

We have installed the Implementation 2.0 connector on the computer running the gateway and now getting the following error:

 

Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details
Activity ID: 0f1e1e33-b5f7-4403-b727-a5f52a9598a3
Request ID: def25b76-7146-789a-c0f0-d2093d99a8e6
Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net
Status code: 400
Error Code: DMTS_PublishDatasourceToClusterErrorCode
Time: Wed Oct 03 2018 15:40:47 GMT+0100 (GMT Summer Time)
Version: 13.0.6781.189

Webmi: Invalid connection credentials.
Underlying error code: -2147467259
Underlying error message: The credentials provided for the SapBusinessWarehouse source are invalid. (Source at dunv-bw7-p2/00/900.)
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.CredentialError.DataSourceKind: SapBusinessWarehouse
Microsoft.Data.Mashup.CredentialError.DataSourcePath: dunv-bw7-p2/00/900
Microsoft.Data.Mashup.CredentialError.Reason: AccessUnauthorized
Microsoft.Data.Mashup.MashupSecurityException.DataSources: [{"kind":"SapBusinessWarehouse","path":"dunv-bw7-p2/00/900"}]
Microsoft.Data.Mashup.MashupSecurityException.Reason: AccessUnauthorized
gateway3: The gateway is either offline or could not be reached.

Troubleshoot connection problems

Anonymous
Not applicable

Hi, has anyone else had an issue adding SAP BW to the Enterprise Gateway since using Implementation 2.0?

 

Thanks

 

Mike

HI @Anonymous,

 

I test with implantation 2.0 connector without your issue, it works well on my side.('import' mode with sap warehouse application server)

 

>>Underlying error message: The credentials provided for the SapBusinessWarehouse source are invalid. (Source at dunv-bw7-p2/00/900.)

 

In addition, it mentioned credentials error in error message, have you test on desktop side to ensure your credentials works? Is there any changes on your credentials?

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Anonymous
Not applicable

Hi,

 

Thanks for testing.

 

My credentials work fine on desktop side. We need to move the gateway to a new server so will see if the issue still persists after that.

 

Regards

 

Mike

We have the same problem since moving to the gateway 2.0 connector (I did have it working with 1.0).

I have also installed the latest (March 2019) version of the gateway and the problem persists.

I have opened a call with Microsoft and they have traced it to the language (EN in my case) not being passed through as it is in Desktop.  This causes SAP to reject the connection.

However, in the gateway connector there is no option to set the language.

Does anyone know if it is possible to set the language on the SAP side of the connection?

 

 

Hi @HMJSomerset 

 

we have set the Logon langauage default to EN, see below, but still coming up with the same error message. Any ideas on who could help?

 

thanks Ed

EN.PNG

 

 

Hi @HMJSomerset 

 

we are also experiencing the same issues, interesting to know its becuse of the language, have you had any response yet as to whether this can be done on the SAP side?

 

thanks Ed

Hello,

were you able to find a solution to this issue?

 

 

Hi  @Garybe 

 

nothing as yet, are you experieincing the same issues?

 

thanks Ed

@EdEvetts ,

I've indeed experienced the same kind of issue.

Same error message.

weirdly enough, I could make it work when installing the gateway as personal mode, but this is not a long term solution. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors