cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Prodigy
Post Prodigy

not enough space on the disk

Hi,

 

Got message below when running report through gateway on service - 300 or so mb so quit ebig but way under 1gb.

 

Will look to check gateway disk space but had over 50 GB yesterdya thus should be O.K.

 

Also the table_name quite a smsall table 2 million rows approx.

 

Thoughts how best resolve if enough space on gateway server.

 

Data source error{"error":{"code":"DM_GWPipeline_Gateway_GatewayOutOfDiskSpaceError","pbi.error":{"code":"DM_GWPipeline_Gateway_GatewayOutOfDiskSpaceError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"There is not enough space on the disk.\r\n"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147024784"}}],"exceptionCulprit":1}}} Table: <table_name>

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: not enough space on the disk

Hi, @po 

 

I'd like to suggest you refer the following check list.

1. Make sure the disk where the gateway installed has enough available space.

 

2. The Mashup Engine stores caching files in your user appData local directory - i.e., not necessarily the drive where you installed PowerBI Desktop. Make sure there is enough space on your user folder as well (and there isn't a quota on it). You may also check your cache size by going to Options -> Global -> Data Load -> Data Cache Management Options

 

3. If the error still exists, kindly raise it to the support team for better advice:

https://powerbi.microsoft.com/en-us/support/ 

 

Best Regards

Allan

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: not enough space on the disk

Hi, @po 

 

I'd like to suggest you refer the following check list.

1. Make sure the disk where the gateway installed has enough available space.

 

2. The Mashup Engine stores caching files in your user appData local directory - i.e., not necessarily the drive where you installed PowerBI Desktop. Make sure there is enough space on your user folder as well (and there isn't a quota on it). You may also check your cache size by going to Options -> Global -> Data Load -> Data Cache Management Options

 

3. If the error still exists, kindly raise it to the support team for better advice:

https://powerbi.microsoft.com/en-us/support/ 

 

Best Regards

Allan

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Post Prodigy
Post Prodigy

Re: not enough space on the disk

Hi,

 

Thanks for update

Helpful resources

Announcements
May 2020 Community Highlights

May 2020 Community Highlights

It’s time for another PBI Community recap!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Galleries

Galleries

Looking for inspiration on how to present your data? Need instructional videos? Check out our Galleries!

Top Solution Authors
Top Kudoed Authors