cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vishwa_molex Frequent Visitor
Frequent Visitor

<pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

We are tesing direct Bex query with power BI services. 

From desktop am able to connect to Bex query and create the dashbaord. 

when I publish the same it gets success with message " Publishing is succeeded. The published report has configred to use an enterprise gateway" 

 

But when I try to refresh the same from service it givews the belwo message:

( WE HAVE Oct 2018 Gateway  version and DATA SOURCE CREATED FOR BW server with kerberos SSO authentication)

 

Cannot connect to the mashup data source see error details for more information 

 

Error Details : 

Cannot load model
Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.
Please try again later or contact support. If you contact support, please provide these details.
Underlying error code: -2147467259
Underlying error message: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>
Correlation ID: e7b9a552-04c3-1f1f-5752-4a313f8dabd7
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.ValueError.Reason: Expression.Error
Activity ID: 6d1293ab-c3e8-47d5-8508-b7a29b174415
Request ID: 8910945a-000b-9aea-fb46-10f72fe9ad21
Time: Fri Jan 04 2019 12:13:47 GMT-0600 (Central Standard Time)
Version: 13.0.7840.211
Cluster URI: https://wabi-us-north-central-redirect.analysis.windows.net

16 REPLIES 16
Community Support Team
Community Support Team

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Hi @vishwa_molex,

 

Based on the error message, I'm afraid that the data you refreshed is not mached with the data you import, please check if the data in data source is changed the data type.

 

By research, it seems that this error may be casued by power query. 

 

You could refer to this similar thread and have a try.

 

https://community.powerbi.com/t5/Integrations-with-Files-and/The-import-Percentage-Type-matches-no-e...

 

https://social.technet.microsoft.com/Forums/en-US/cfe5c277-5cef-4b7e-91a9-f49524c9f0fe/expression-er...

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Hi @vishwa_molex,

 

Have you solved your problem?

 

If you have solved, please always accept the replies making sense as solution to your question so that people who may have the same question can get the solution directly.

 

If you still need help, please feel free to ask.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
garryphipps Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Hi

Did you manage to solve this problem?  We are experiencing the exact same issue

Regards

Garry

vishwa_molex Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Garry,

 

I have not found the solution to this. Still working with MS and they are not able to findout the cause for this.

Thanks

 

 

vishwa_molex Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

I have not found the solution for this.

vishwa_molex Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Hi Garry,

 

Incase if you find the solution please update the same here.

 

Thanks.

 

vishwa_molex Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Any luck with this ?

 

Thanks

garryphipps Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Yes i did.  in my case the issue was incorrectly configured SNC Partner name in the gateway connection.  The issue was the format of the SNC Partner name in the gateway.  it needs to be set in the following format

p:SAP/ServiceAccount@somedomain.com

 

ServiceAccount = the SPN you have configured for BW Kerberos authentican

somedomain.com = this is your corporate domain

 

vishwa_molex Frequent Visitor
Frequent Visitor

Re: <pi>The import [0CALMONTH] matches no exports. Did you miss a module reference?</pi>

Hi,

We have all these settings I still get this error.

Can you please let me konw if you are using  SSO to BW via gsskrb5  or CommonCryptoLib?

We are  use gsskrb5 .

 

Thanks

V

Helpful resources

Announcements
Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Top Kudoed Authors
Users Online
Currently online: 67 members 1,275 guests
Please welcome our newest community members: