cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

issue with enhanced compute engine settings for dataflow - workaround is to DISABLE

Hi,

 

I posted yesterday about refresh issues in Dataflows.

 

I've found a work around.

 

Background : I have an ingestion workspace which has dataflows that ingest data from sql.  no issues with these.  I have a curated workspace which links to these dataflows and applys some transfromations.  These have stopped working since the Sep 24.

 

I found that by changing the settings for the enhanced compute engine settings from OPTIMISE to DISABLE on the dataflow they have started working again.

 

Still have an active microsoft case going but sharing here, in case others are seeing it.

4 REPLIES 4
Community Support
Community Support

Hi @frano72,

Thanks for sharing, I think this workaround will help others who faced similar issues.

BTW, did this issue only appears on a specific Datasource type/workspace? What type of operations did you apply to these dataflows? Please share detail to help us troubleshoot and find out the root casing of these issues.

How to Get Your Question Answered Quickly 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Hi @v-shex-msft - the data sources are linked entities from another dataflow in another workspace.

 

Its really simple transformation.

 

I link to one entity from another workspace - ensure its set to load.

 

Create a reference query from this.  The transforms to this are 

 

make a columns a key : 

Table.AddKey(Source, {"LoadID"}, false)
 
change two columsn data type :
Table.TransformColumnTypes(#"Marked key columns", {{"TruckSAPID", Int64.Type}, {"ShovelSAPID", Int64.Type}, 
 
thats it.
 
The refresh error is :
Error: Compute engine failed: Insufficient memory. Please increase your compute engine/workload memory and try again. (8645). Details: A timeout occurred while waiting for memory resources to execute the query in resource pool 'default' (2). Rerun the query.
 
Tempting to think that need to give more memory to dataflows.
 
However - one thing all of us in IT are good at is picking trends.  There was a definate watershed moment on Sep 24/25 where things were working and now not working....an aligns with updates made to power bi service announced at Ignite...
 
MS Support are looking into it...
 
 

Hi @frano72,

I  think it probably related to premium workload settings.

You can refer to the following link to know the resource setting of premium capacity and ask the admin to check if your resource exceeds the limit/settings.

Configure workloads in a Premium capacity 

Regards,

 

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

@v-shex-msft  - Hi, I think there is still an issue with the Service but I realise now what is going on.

 

The deeper understanding came from  Mattew Roches excellent blog site.

 

https://ssbipolar.com/2020/09/16/dataflows-enhanced-compute-engine-will-it-fold/

 

basically I was thinking about it wrong (but it still should not have affected it).

 

The compute engine should be used for the ingestion dataflows.  There is no need to use the compute engine for the transformation dataflows.  It’s the transformation onces that are accessing the sql cache (ie compute engine) of the ingestion ones.

 

So this explains why it can be  DISABLED for the transformation dataflows (what i originally thought was a workaround)

 

However – when the setting is set to OTPIMISE – it should realise that those entities are NOT linked to any further downstream dataflows and therefore should be equivalent to an DISABLED state.

 

So this is where I do think something has changed in the way this aspect works.  Before Sep 24 an OPTIMISE setting was correctly determining these dataflows aren't linked anywhere else therefore treat as DISABLED.  Since Sep 24, that logic isn't working, and workaround is to MANUALLY set them to DISABLED.

 

Helpful resources

Announcements
secondImage

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

secondImage

Power BI Women

Join our monthly meetings and learning sessions.

secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors