cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bbobillier
New Member

dataflow refresh failing with "invalid credential" when merging 2 tables

Hello,

 

I have a dataflow with 2 Tables

TableA contains the "Table A" object from an xls source file stored in the sharepoint site linked to our service environment

TableB contains the "Table B" object from the same xls source file

 

When I do a service refresh (manual or scheduled) with the above it completes succesfully.

 

Then I try to add to TableA 4 fields from TableB with a merge query function.

While I am in the dataflow editor, it works. I can see the additional values.

When I do a service refresh (manual or scheduled), if fails on the TableA with the error message 

Error: The credentials provided for the PowerBI source are invalid. (Source at PowerBIInternal.).

 

I looked at the credential, they are OAuth2, I tried all the Privacy level settings but nothing solved the issue.

 

Thank you for your help

Bertrand

 

 

 

 

 

 

2 REPLIES 2
InsightBob
Frequent Visitor

Probably linked to this:

 

https://powerbi.microsoft.com/en-us/support/

 

check the 'awareness' section

yes this is due to this linked entitiy issue in the service environment. I worked around it be duplicating the TableB, not enabling load on this duplicate item and doing the merge with this duplicate item.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!