Showing results for 
Search instead for 
Did you mean: 
New Member

dataflow refresh failing with "invalid credential" when merging 2 tables



I have a dataflow with 2 Tables

TableA contains the "Table A" object from an xls source file stored in the sharepoint site linked to our service environment

TableB contains the "Table B" object from the same xls source file


When I do a service refresh (manual or scheduled) with the above it completes succesfully.


Then I try to add to TableA 4 fields from TableB with a merge query function.

While I am in the dataflow editor, it works. I can see the additional values.

When I do a service refresh (manual or scheduled), if fails on the TableA with the error message 

Error: The credentials provided for the PowerBI source are invalid. (Source at PowerBIInternal.).


I looked at the credential, they are OAuth2, I tried all the Privacy level settings but nothing solved the issue.


Thank you for your help








Frequent Visitor

Probably linked to this:


check the 'awareness' section


yes this is due to this linked entitiy issue in the service environment. I worked around it be duplicating the TableB, not enabling load on this duplicate item and doing the merge with this duplicate item.

Helpful resources

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!


Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors