cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dhooger
Helper I
Helper I

data refresh timeout - works sometimes, fails others

I'm trying to support a Power BI dataset reading from SSAS.

 

It will NOT refresh from the schedule from Power BI Service. "DataSource.Error AnalysisServices: XML for Analysis parser: The XML for Analysis request timed out before it was completed.."

 

When I try to refresh from Power BI Desktop, sometimes it works. Sometimes it doesn't. It depends on the machine and time.

 

Things I've tried

1) going to SSAS, properties, Show Advanced (All) Properties, ExtendedTimeout and setting that to 60000, which I believe should be 10 hours. The refresh when done on Desktop takes about an hour.

2) In the PowerBI file, I've gone to advanced editor in the edit queries and added,

Source = AnalysisServices.Database("SERVER", "DB", [TypedMeasureColumns=true, CommandTimeout=#duration(0,2,0,0)]),

 

It needs to refresh from PBI Service.

1 ACCEPTED SOLUTION

I worked with Microsoft support for a month. The primary answer was that the ExtendedTimeout needed to be moved from 3600 seconds out to more than an hour. Unfortunately, that didn't work still. Overall the answer is that one shouldn't try to import that much data from an MDX model if it takes more than an hour.

View solution in original post

6 REPLIES 6
Lewis-H
Responsive Resident
Responsive Resident

The notification function basically builds up a generic HTML email that I intend on using for more PowerShell scripts & error handling, so feel free to adjust as you wish. I replicated the style of the Power BI failure notifications as a quick, clean solution. There’s even a parameter to pass a hex colour to this function, so you can colour code your emails! If you need to authenticate to your mail server, we can use a similar method to the authentication function, by using an encrypted text file. I have included this and added a switch (-auth) when calling the script to enable that functionality.

webportal
Impactful Individual
Impactful Individual

You can try incremental refresh.

If you have a Pro account, it is now generaly available.

If not, you may write the contents of the older data (the one you wish to keep frozen) into a csv or txt file and refresh only the newer data. This will speed up the refresh duration and prevent timeout errors.

Greg_Deckler
Super User
Super User

You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


@ me in replies or I'll lose your thread!!!
Check out my External Tool for Power BI Desktop! Microsoft Hates Greg's Quick Measures
YouTube Channel! Microsoft Hates Greg
Check out my latest book!

i had to submit as support ticket.

Hi @dhooger ,

 

Has your problem been solved?

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I worked with Microsoft support for a month. The primary answer was that the ExtendedTimeout needed to be moved from 3600 seconds out to more than an hour. Unfortunately, that didn't work still. Overall the answer is that one shouldn't try to import that much data from an MDX model if it takes more than an hour.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors