cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
majdkaid22
Helper V
Helper V

dashboard are blank

Hi guys,

 

is there anyone out there facing a problem with the dashboard not showing the values?

 

this has been happening since the morning today

 

Screen Shot 2017-10-15 at 6.11.38 PM.png

15 REPLIES 15
GilbertQ
Super User
Super User

Hi @majdkaid22

 

Are you using DirectQuery/Live Connection?

 

And also have you cleared out your browser cache to ensure that it is not causing any issues?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

@GilbertQ it's a load mode Dataset. I did what you suggested. The problem is for all users in my company when they are accessing dashboards coming from this particular DataSet

Hi @majdkaid22

 

Another question to ask is did you enable any Row Level Security on your data model?

 

You can check this by going into the dataset and then clicking on Security. 

When this opens if there are any Roles in Security, then that could possibly why it is not showing any data?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

@GilbertQ I actually made sure this option is enbaled. dasbhaords were up to yesterday all working fine. Nothing has changed in the settings.

 

It's worth mentioning that i moved the DataSet (desktop file) to a new VM, but it's been connected and auto refresh is working as expected. Reports are working, but dashboards are not working

Hi @majdkaid22

 

I am then not sure why the dashboard is not working if your reports are working well.

 

What happens if you had to create a new dashboard item and pin it to your existing dashboard, do you see it?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

thanks for the tip @GilbertQ any new widgets I add now are appearing on the dashboard. Funny enough, the old widgets in the dashboards have no delete appearing in the drop-down ... only export to excel or go to report. 

 

Not sure how will delete them now...

That is indeed weird.

 

I am not sure why that is happening. Is this dashboard in an App Workspace or in your Personal Workspace?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Same issue here, even re-pinned tiles are not working correctly and really there is no way of fixing it as we can not delete the tiles. Issue happens in dashboards in  an App Workspace which was working perfectly for about a year. Issue is confirmed in a couple of other community posts as well:

 

I just removed all RLS settings on the underlying dataset and republished, the tiles are working are expected right now. I will try to reset the RLS, republish and see what happens. Not sure why though, there was no change in the RLS settings anyway.

If I remove all RLS now, it will be a nighmate. I have 65 Sales users that will lose access to their data

Hi

 

I have the same issue with RLS security. If I remove it from PBI Desktop it works.

 

It might be an issue from the microsoft cloud plateform right? How can we register a ticket for this issue? A post in this forum is good enough?

OL
Frequent Visitor

Accurate description.

The situation with our models - is exactly as described.

The moment we canceled the RLS from the desktop - the dashboard on the server worked fine. When we returned the RLS, the dashboard stopped working.

ArupC
Advocate II
Advocate II

Facing the same issues for last 3-4 days.. Dashboards are blank or partial.. This seems to be bug in Microsoft server wherein RLS is not working only in dashboard tiles. Going to reports is working fine

 

Dear Microsoft - Pls look into this issue.. Users are unable to consume dashboard both on service and mobiles.

 

Regards,

 

Arup

Hi All,

 

It seems to a known issue.

 

issue1.PNG

Hey all - there is currently an issue where dashboard tiles built on datasets with Row-Level Security enabled will not load for end users. It will continue to work for those with edit permissions on the content. I believe that is causing the issues mentioned here. If anyone here is seeing the same issue on a dataset without Row-Level Security, please let us know.

 

The workaround in the meantime is to navigate to the report by clicking on the tile. 

 

We are working on a fix for this as quickly as possible.



As @sirui_sun has mentioned in this similar thread, the workaround in the meantime is to navigate to the report by clicking on the tile. And they are working on a fix for this as quickly as possible. Smiley Happy

 

Regards

Hey all - This issue should now be fixed - dashboard tiles built on RLS datasets should now render correctly. -Sirui

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.