cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dtran
Helper II
Helper II

can not refresh dataset (both from 'refresh now' and 'schedule refresh'

-setup gateway and connection

-connection works when tested

-however, both manual refresh and schedule refresh failed. here is the error message:


"A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The received certificate has expired.)"

 

1 ACCEPTED SOLUTION

I was able to resolve it by:

1) uninstalling on-premises data gateway

2) using Power BI - personal.

 

See here for solution: http://community.powerbi.com/t5/Service/Enterprise-gateway-quot-cannot-connect-to-the-mashup-data-so...

 

View solution in original post

6 REPLIES 6
dregan
New Member

I had this issue, and none of the online resolutions worked.  The certificate was not expired, even though that was the error we were receiving.   We followed these steps:


Open SQL Server Configuration Manager, expand SQL Server Network Configuration, right-click Protocols for<server instance>, and then select Properties. On the Certificates tab you should see the details of the certificate that SQL Server is trying to use.

 

The certificate was blank by default but when we clicked the dropdown, it appeared.  We selected the certificate, hit apply and then needed to restart the SQL Server service. After we did this, the refreshes worked. 

jajacques
New Member

Just for anyone else who ends up on this thread as I did - I had a similar issue but quite different.

 

At one time we had purchased Entrust certificates to use for Encryption in Flight use between SQL Servers and some Oracle BI solutions. The database we were attempting to connect to had some old remnants of the expired certificate that was no longer being used. The thumbprint was not removed from the registry entry and the certificate was still present in the certificate store.

 

This was the reg key to remove the value of:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11.InstanceName\MSSQLServer\SuperSocketNetLib\

 

Key: Certificate

 

Once this was removed from the registry and the certificate was deleted (even though SQL was not using the certificate correctly) - I restarted the instance, and I was able to schedule refreshes through my Enterprise Gateway without issue.

 

v-ljerr-msft
Microsoft
Microsoft

Hi @dtran,

 

According to the error message, I found a similar thread here in which a solution was mentioned that go to 'Data Source Settings' then unchecked the 'encrypt connections' check box (for the data source). Could you go to check if it helps?Smiley Happy

 

Regards

Hi @dtran,

 

According to the error message, I found a similar thread here in which a solution was mentioned that go to 'Data Source Settings' then unchecked the 'encrypt connections' check box (for the data source). Could you go to check if it helps?Smiley Happy

 

Regards

-------------------------

 

 

This helped me.

I work with the on-premise version of Power BI Report Server (SSRS). 

Hi v-ljerr-msft,

 

I have tried that and I'm still getting the same error.

Any other feedback would be appreciated.

 

thanks!

 

I was able to resolve it by:

1) uninstalling on-premises data gateway

2) using Power BI - personal.

 

See here for solution: http://community.powerbi.com/t5/Service/Enterprise-gateway-quot-cannot-connect-to-the-mashup-data-so...

 

View solution in original post

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!