cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Zikan Frequent Visitor
Frequent Visitor

YOU DON'T HAVE ANY DATA GATEWAY

Hello,

 

Today I noticed that my reports wasn`t working anymore. I looked at my Data Gateway and saw that "powerbi couldn't reach to the gateway" 

 

I updated the on-premises data gateway, removed the gateway to build another one and now it shows that I have no gateway.

 

I  appreciate your assistance 
image.pngimage.png

1 ACCEPTED SOLUTION

Accepted Solutions
Zikan Frequent Visitor
Frequent Visitor

Re: YOU DON'T HAVE ANY DATA GATEWAY

Hello @GilbertQ and @v-xicai  !

 

Looking for it, I found the problem and I fixed it. Thank you very much for your help guys!

I'm describing below the issue and how I fixed it.

 

--------------------------------------------------------------------------------------------------------

I have 2 microsoft accounts with the same address( 365 account and an enterprise account) = ti@grieg.com.br

But to use powerbi with this account, microsoft created other address (ti@griegsto.onmicrosoft.com) . 

 

In the past, when I first install my gateway, I used ti@grieg.com.br . And for some reason, powerbi services could not reach to the gateway anymore. 

At the time that I put the ti@griegsto.onmicrosoft.com account address, powerbi services found my gateway. 

-------------------------------

Conclusion: The account used in my gateway isn't the same account used in my powerbi services panel. 

Thank you again for your time. 

 

 

View solution in original post

7 REPLIES 7

Re: YOU DON'T HAVE ANY DATA GATEWAY

Hi there

When you say you removed the Gateway, did you remove it from the Power BI Service?

If so you would need to re-create this as part of the setup of the Gateway.

Also if you did delete the Gateway from the Power BI Service you would have also lost all your data sources, unless you have got the recovery key from the first install?

Did I answer your question? Mark my post as a solution!
"Proud to be a Datanaut!"
Power BI Blog
Community Support Team
Community Support Team

Re: YOU DON'T HAVE ANY DATA GATEWAY

Hi @Zikan ,

 

As GilbertQ said, you may need to add data source settings under Mange gateway , see more: Manage data sources, Merge or append on-premises and cloud data sources. You can also configure schedule refresh for the dataset, see Configure scheduled refresh.

 

63.png

 

In addition, you could get your original data source settings again via the recovery key, while you can't find it if you haven't kept this key before. You can refer to the link to learn how to migrate an Existing On-Premises Data Gateway for Power BI.

 

Best Regards,

Amy

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Zikan Frequent Visitor
Frequent Visitor

Re: YOU DON'T HAVE ANY DATA GATEWAY

Thanks for answering! @v-xicai @GilbertQ 

 

When I said that I removed the gateway, I removed from PowerBI services and unistalled the On-Premisses Data Gateway from the working station. 

 

I re-installed the On-Premisses Data Gateway on the working station like the image above "GRIEG_TIGTZ" but at the Manage Gateway Panel it doesn't show.

 

Am I missing any step? Do I have to do anything else?

 

image.png

 

 

Zikan Frequent Visitor
Frequent Visitor

Re: YOU DON'T HAVE ANY DATA GATEWAY

Guys!

 

looking for the problem, I just saw the loggin and it shows the following error:

 

[DM.Analytics] Performance counters not installed, application performance metrics will not be traced (category = Microsoft Power BI Enterprise Gateway)

 

image.png

Re: YOU DON'T HAVE ANY DATA GATEWAY

Hi there

It would appear that there is something going wrong during your Gateway installation.

Could you uninstall and make sure that the folder has been removed under C:\Program Files\On-premises data gateway

Did I answer your question? Mark my post as a solution!
"Proud to be a Datanaut!"
Power BI Blog
Zikan Frequent Visitor
Frequent Visitor

Re: YOU DON'T HAVE ANY DATA GATEWAY

Hello @GilbertQ and @v-xicai  !

 

Looking for it, I found the problem and I fixed it. Thank you very much for your help guys!

I'm describing below the issue and how I fixed it.

 

--------------------------------------------------------------------------------------------------------

I have 2 microsoft accounts with the same address( 365 account and an enterprise account) = ti@grieg.com.br

But to use powerbi with this account, microsoft created other address (ti@griegsto.onmicrosoft.com) . 

 

In the past, when I first install my gateway, I used ti@grieg.com.br . And for some reason, powerbi services could not reach to the gateway anymore. 

At the time that I put the ti@griegsto.onmicrosoft.com account address, powerbi services found my gateway. 

-------------------------------

Conclusion: The account used in my gateway isn't the same account used in my powerbi services panel. 

Thank you again for your time. 

 

 

View solution in original post

Re: YOU DON'T HAVE ANY DATA GATEWAY

That is great, thanks for letting us know how you solved your issue!

Did I answer your question? Mark my post as a solution!
"Proud to be a Datanaut!"
Power BI Blog

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (1,770)