cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
danielveloso92
Frequent Visitor

Xero Custom Connector by Fresh BI doesn`t refresh in PBI service

Hi Community,

 

Happy new year to all! Now jumping back to our reality.

I'm developing a P&L report with data provided by Xero Api OAuth V2. I'm using a local custom connector provided by  Fresh BI which has been working perfectly within PBI Desktop. My current problem is that I didn't manage to refresh it in PBI service. It gives me the following error.

 

danielveloso92_0-1609941811528.png

 

Note that, under the Schedule Refresh option the Gateway ribbon doesn't show up. 

PBICOMMUNITY1.png

 

I have got a personal gateway set and I also can see my connector there named "Xero".

danielveloso92_0-1609944923045.png

 

 

 

PS: I wonder if the reason for this issue is the name of the file.pqx and the connector in the get data windows being different.

Connector Received.

PBICOMMUNITY3.png

 

Get Data Connector

PBICOMMUNITY4.png

Any help would be greatly appreciated.

 

Thanks

Daniel

 

 

 

 

 

 

 

 

 
 
 

 

7 REPLIES 7
Eyelyn9
Community Support
Community Support

Hi @danielveloso92 ,

 

Could you tell me if your problem has been solved? If it is, kindly Accept it as the solution. More people will benefit from it.

 

Best Regards,
Eyelyn Qin

Hi @Eyelyn9 ,

I still haven`t sorted it. Thanks for asking

 

Best Regards,

Daniel

Eyelyn9
Community Support
Community Support

Hi @danielveloso92 ,

 

Sorry, I have not done a lot of work with Xero custom connectors. Maybe you could kindly take a look at the blog for further help.

 

In addition, please pay attention to the considerations and limitations refered in the official document:

  • For custom connectors to work with the on-premises data gateway, they need to implement a “TestConnection” section in the custom connector’s code.
  • OAuth for custom connectors via gateways is currently supported only for gateway admins but not other data source users.
  • If your custom connector is on a network drive, include the fully qualified path on the on-premises data gateway app.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi Daniel!

 

This sounds like it could be a gateway configuration issue. Does your gateway setup look anything like below?

MicrosoftTeams-image.png

I'd recommend checking out Microsoft's documentation for using custom connectors with on-premises data gateways. A couple other points to consider:

  • double check that your custom connector is visible in the gateway under Custom data connectors
  • make sure that you have allowed custom data connectors to refresh through the gateway
    • as of May 2020, this is the middle checkbox on the gateway settings in the service

Hi Jose

 

I have managed to pick the Xero Connector on the data source type field. I basically dropped the custom connector folder in the root C: then the list of connectors started showing up like it was in the personal gateway and that advice vanished. 

See how is my data source from the gateway in the pic below. I have signed in and granted it to a few organizations. 

danielveloso92_1-1610116022617.png

After it all, I still can`t see the gateway ribbon.

danielveloso92_2-1610116317841.png

Thanks

Daniel

 

 

Hi Jose,


Firstly, I really appreciate the quick response and your time.

I have been trying with the Personal Gateway so far. After your response, I have tried to use the Enterprise gateway but I did not manage to make the custom connector to show up in the "Data Source Type" field. Would it work using a personal gateway? 

I have ticked the box which allows custom connectors. And, under the gateway settings, I can't see the custom connector like I used to see when using the personal gateway. It has advice instead, asking to make sure if the service gateway account has access to the connector folder (I did not find anything about it). See the below.

PBICOMMUNITY5.png

Thanks

Daniel

Hi @danielveloso92 ,

 

We have updated the connector, I believe this has fixed the above issue. Please can you check your inbox for a new copy.

 

If you do not have it please reach out so we can send you a copy.

 

 

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.

Top Solution Authors
Top Kudoed Authors