cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mmace1
Post Prodigy
Post Prodigy

Why was Dataset *build* access needed for Users to get access to a report?

I have a Composite Model Report in Workspace 1 , that pulls from:

 

  • Via Direct Query, Dataset A in Workspace 2
  • Via Import, several additional tables

 

Because the Report lives in a different Workspace than Dataset A, I've had to specifically give Users *read* permissions for Dataset A.  Pretty...pretty sure just Read permissions

Until today, when users suddenly get "Couldn't load the data for this visual" errors.

It's fixed if I add *build* permissions to Dataset A. But, why...?

 

 

8 REPLIES 8
v-xulin-mstf
Community Support
Community Support

Hi @mmace1,

 

Refer to this post here. Your problem might be related.

The error you mentioned here is usually a transient issue, which I think might be related with the Data Source connection. Please try it again and see what happens.

 

Best Regards,

Link

 

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

@v-xulin-mstf  Issue is still present. 

If I remove the build permissions, then users again get the "Couldnt load the data for this visual" error

Hi @mmace1,

 

Any RLS setting on published report? If this is a case, you need to assign roles to users.

Row-level security (RLS) with Power BI

 

Best Regards,

Link

@v-xulin-mstf 

Thanks.  No RLS involved.  But  I have it working - just the users need read *and* build permission on the dataset suddenly, and several other users are reporting the same sudden experience. 

Hi @mmace1,

 

It is a known issue that Microsoft is currently working on. ICM: 218686013

I will update here when i got any response.

 

Best Regards,

Link

@v-xulin-mstf 

Was there ever any update to this?  i.e. - live with it, or planned fix in Q2, etc?   I tested today, and the issue still seems to be present. 


Same issue in our setup, waiting for resolution and update!

Anonymous
Not applicable

I have the exact same issue. It seems like something has changed. 

I have a New Composite Model that uses a Power BI "Golden Dataset" in a separate work space as direct query. Then has a few tables that Import.
Users who have read access to the Golden Dataset are getting the "Couldnt load the data for this visual" error.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors