cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
alextas Frequent Visitor
Frequent Visitor

Visual failing to load due to function I'm not using

I work for an irrigation development company. The visual in question is a matrix with information like dam names, water storage levels, differences, and so on.

 

On the online report, the visual fails to load with the following error message:Screenshot from 2017-08-23 12-08-49.png

 

This does not happen in the desktop version of PowerBI and the visual loads fine.

 

I'm not using the ADDMISSINGITEMS function anywhere in the report, and only one table has a column named 'Dam Type' (which the visual has a lookup for). The table is constructed with the formula 

DataDamCW = FILTER(DataDamAll, NOT(ISBLANK([Dam ID])) && RELATED(Calendar[IsCurrentWeek]))

and the table containing 'Dam Type' has a *:1 relation on DamDataAll.

 

I don't know when this issue started as I was on leave when it first occurred, but it may have been sometime around April or May (definitely after Feburary).

3 REPLIES 3
Community Support Team
Community Support Team

Re: Visual failing to load due to function I'm not using

Hi @alextas,

 

Can you share some detail contents about this issue?(For e.g. datasource, connection modle, formulas...)

It is hard to reproduce your issue without any detail information.

 

In addition, you can also try to use below formula to filter non blank related records if it suitable for your requirement:

DataDamCW = CALCULATETABLE(DataDamAll, Values(Calendar[IsCurrentWeek]),ALLNOBLANKROW('DataDamAll'[Dam ID]))

 

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
alextas Frequent Visitor
Frequent Visitor

Re: Visual failing to load due to function I'm not using

The data sources are a SharePoint list (dam info, the lookup table) and an Excel spreadsheet hosted on SharePoint (for the actual data). The current week data is a filtered version of the Excel data.

 

Below are the relations between the relevant tables:

- DataDamCW and InfoDam are linked on Dam ID/ID, a unique integer for each dam.

- InfoDam and DataDamAll are linked on Dam ID;

- DamDataAll and CalendarMeasures are connected on the date.

Screenshot from 2017-08-24 13-32-18.png

 

I'm not too sure what to include for formulas, since most of the calculated columns on each table aren't relevant for the matrix that's having issues. I've included the formula for DataDamCW in the original post.

 

Your provided formula unfortunately breaks my relationships (likely not the ones in this network), so it doesn't accept it, but thanks.

Community Support Team
Community Support Team

Re: Visual failing to load due to function I'm not using

Hi @alextas,

 

If you modify the 'cross filter direction' option to 'both', does this issue appears again?

Since I can't reproduce your issue, you can also try to submit a ticket for further support.

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |

Helpful resources

Announcements
New Ranks and Rank Icons in 2020

New Ranks and Rank Icons in 2020

Read the announcement for more information!

New Kudos Given Badges Coming

New Kudos Given Badges Coming

We're rolling out new Kudos Given badges. Find out how many Kudos you've given.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)