cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Visio Visual - Too Many Shapes

Hi all,

 

I am trying to bring in an org chart for under 300 people into PowerBI and am getting the error that there are too many shapes to display in PowerBI.  I know the limit is 1,000.  After some investigation, I found that for each 'shape' representative of a person, it adds 10 shapes to the layer.  I have tried removing data I had imported and the photo box. only the latter made an impact, reducing from 10 shapes to 9 shapes per resource. 

 

Has anyone else encountered this issue and identified how to overcome it.  I have looked in Visio forums and can't see it there either although I imagine this would moreso be an issue unique to use in PowerBI.

 

This is time sensitive reporting, any urgent feedback would be hugely appreciated.

 

Thanks

KC

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Visio Visual - Too Many Shapes

Hi all,

 

I've been able to find a solution as provided by the Tell Visio team.  I recommend using Workaround 3 with the Unique Key Workaround.  They can be completed at the same time when in the stencil to save time. The latter is required because by selecting only 1 shape to pull through to a # layer in workaround 3, the unique key data is not pulled through with it into PowerBI and hence the automapping cannot take place.

 

Problem:
The shape that I used (ie. in the org chart) is a group shape and has 10 shapes within it. It has properties that protect the shape which inhibit selecting sub-shapes or even ungrouping the group shape. 

 

Workarounds:

  • OPTION 1 Go to home tab > Tools group> Rectangle shape > Add a rectangle on top of each shape > Add this shape to the # layer (i.e. single shape) > Format this shape to remove fill and line colors OR just add a rectangle shape from Basic shapes stencil. [Dirty workaround but easiest]
  • OPTION 2 Go to Developer tab. If you can’t see developer tab, go to file > options > customize ribbon > Enable developer tab. In developer tab > Look for Drawing Explorer in the far right of the ribbon > find the rectangle sub-shape in the executive belt shape > right click and add to the # layer. This will add just the sub-shape to the # layer. You’ll have to do this for all shapes in your diagram.

Point 2 diagram.jpg

  • OPTION 3 Changing the master shape itself which means you do this once and it will add the right shapes to the # layer in one go, hence my favorite workaround for the time-being (users usually don’t edit master shape, because it affects all shapes but then that’s what we want in this scenario right?)
    1. Go to developer tab
    2. Open document stencil (will show below your stencils in the stencil pane)
    3. Right click on Executive belt shape > Edit master shape
    4. Keep expanding the shapes on the left till selecting a shape in the document stencil highlights (grey boundary around your shape) the rectangle that we want to add to the # layer
    5. Right click > Layer > Add to a # layer
    6. Now when you close this window, it will ask if you want to update the master and its instances > Click Yes. Now you should see only 1 shape per executive belt shape added to your # layer

 Point 3 Diagram.jpg

 

Unique Key Workaround

  • Go to Edit master shape from document stencil like in solution 3
  • Right click on the shape in master explorer which you just added to the # layer earlier
  • Show shapesheet (shapesheet has meta-data for shapes)
  • Right – click on any value inside the shapesheet
  • Insert Section
  • Check Shape data checkbox
  • Now look for Shape data section and add a formula in the Value field like the below pointing to the shape data field of group shape you want to refer to Shapesheet > Shape Data section > Prop.Row_1 > Value > =Sheet5!Prop.ResourceID
    • Note that Sheet5 is the name of my group shape, it could be different for you.
    • Little pic.jpg
  • Now close the window, you will be prompted to save the master and its instances, choose yes. Now your sub-shape should have shape data that’s a part of your group shape.Big PIc.jpg
  • Now automatic mapping based on Resource ID should work for you.

View solution in original post

3 REPLIES 3
Microsoft v-yulgu-msft
Microsoft

Re: Visio Visual - Too Many Shapes

Hi @KCinMelbourne,

 

It look like you hit the limitation that the amount of shapes are over 1000. Per my research, I didn't find any solution to workaround this limitation. Maybe you could ask for support from tellvisio@microsoft.com.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
shakungrover Frequent Visitor
Frequent Visitor

Re: Visio Visual - Too Many Shapes

Using a # layer helps reduce the number of shapes in such cases.

More on this in the help article here.

 

And yes, please drop us an email at tellvisio@microsoft.com for any further help.

 

Thanks,

Shakun

Program Manager, Visio

Re: Visio Visual - Too Many Shapes

Hi all,

 

I've been able to find a solution as provided by the Tell Visio team.  I recommend using Workaround 3 with the Unique Key Workaround.  They can be completed at the same time when in the stencil to save time. The latter is required because by selecting only 1 shape to pull through to a # layer in workaround 3, the unique key data is not pulled through with it into PowerBI and hence the automapping cannot take place.

 

Problem:
The shape that I used (ie. in the org chart) is a group shape and has 10 shapes within it. It has properties that protect the shape which inhibit selecting sub-shapes or even ungrouping the group shape. 

 

Workarounds:

  • OPTION 1 Go to home tab > Tools group> Rectangle shape > Add a rectangle on top of each shape > Add this shape to the # layer (i.e. single shape) > Format this shape to remove fill and line colors OR just add a rectangle shape from Basic shapes stencil. [Dirty workaround but easiest]
  • OPTION 2 Go to Developer tab. If you can’t see developer tab, go to file > options > customize ribbon > Enable developer tab. In developer tab > Look for Drawing Explorer in the far right of the ribbon > find the rectangle sub-shape in the executive belt shape > right click and add to the # layer. This will add just the sub-shape to the # layer. You’ll have to do this for all shapes in your diagram.

Point 2 diagram.jpg

  • OPTION 3 Changing the master shape itself which means you do this once and it will add the right shapes to the # layer in one go, hence my favorite workaround for the time-being (users usually don’t edit master shape, because it affects all shapes but then that’s what we want in this scenario right?)
    1. Go to developer tab
    2. Open document stencil (will show below your stencils in the stencil pane)
    3. Right click on Executive belt shape > Edit master shape
    4. Keep expanding the shapes on the left till selecting a shape in the document stencil highlights (grey boundary around your shape) the rectangle that we want to add to the # layer
    5. Right click > Layer > Add to a # layer
    6. Now when you close this window, it will ask if you want to update the master and its instances > Click Yes. Now you should see only 1 shape per executive belt shape added to your # layer

 Point 3 Diagram.jpg

 

Unique Key Workaround

  • Go to Edit master shape from document stencil like in solution 3
  • Right click on the shape in master explorer which you just added to the # layer earlier
  • Show shapesheet (shapesheet has meta-data for shapes)
  • Right – click on any value inside the shapesheet
  • Insert Section
  • Check Shape data checkbox
  • Now look for Shape data section and add a formula in the Value field like the below pointing to the shape data field of group shape you want to refer to Shapesheet > Shape Data section > Prop.Row_1 > Value > =Sheet5!Prop.ResourceID
    • Note that Sheet5 is the name of my group shape, it could be different for you.
    • Little pic.jpg
  • Now close the window, you will be prompted to save the master and its instances, choose yes. Now your sub-shape should have shape data that’s a part of your group shape.Big PIc.jpg
  • Now automatic mapping based on Resource ID should work for you.

View solution in original post

Helpful resources

Announcements
New Ranks and Rank Icons in 2020

New Ranks and Rank Icons in 2020

Read the announcement for more information!

New Kudos Given Badges Coming

New Kudos Given Badges Coming

We're rolling out new Kudos Given badges. Find out how many Kudos you've given.

November 2019 Community Highlights

November 2019 Community Highlights

Get an overview of the events and great community content from November.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)