cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
radissoufan
Helper III
Helper III

Using Q&A and Connect Power Bi with Analysis Service

Hello,

I used PowerBI to create a model from an SQL satabase Datasource..

I build model on PowerBI and a Dashboard..

everything went fine and Q&A worked with me fine ..

the problem appeared when I tried to create a PowerBI Dashboard on Analysis Service DataSource..

 the Q&A feature didn't work with me however I activate Q&A feature from site..

 

why it worked with PowerBI model but didn't work with AS model

1 ACCEPTED SOLUTION
v-yuezhe-msft
Microsoft
Microsoft

Hi @radissoufan,

According to your description, you connect live to SQL Server Analysis Services data sources from Power BI Service and wants to use the Q&A feature, right? If that is the case, what version of your SQL Server Analysis Service?

As per this article, currently, the Q&A feature is only available for SQL Server 2016 Analysis Services data sources. Based on my test, when I connect to SQL Server 2016 Analysis Services tabular model, Q&A works as expected, you can check the following screenshots.
1.png2.PNG

However, when I connect to SQL Server 2014 Analysis Services tabular model, Q&A is not working. Thus, please ensure that you are connecting to SQL Server 2016 Analysis Services data sources.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-yuezhe-msft
Microsoft
Microsoft

Hi @radissoufan,

According to your description, you connect live to SQL Server Analysis Services data sources from Power BI Service and wants to use the Q&A feature, right? If that is the case, what version of your SQL Server Analysis Service?

As per this article, currently, the Q&A feature is only available for SQL Server 2016 Analysis Services data sources. Based on my test, when I connect to SQL Server 2016 Analysis Services tabular model, Q&A works as expected, you can check the following screenshots.
1.png2.PNG

However, when I connect to SQL Server 2014 Analysis Services tabular model, Q&A is not working. Thus, please ensure that you are connecting to SQL Server 2016 Analysis Services data sources.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!