cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
caritesh
New Member

Usage Metrics Report (new layout dataset) not refreshing

Hello All, 

 

I had originally accessed the Usage Metrics Report for a workspace back in August 2021. I tried to access the report now but all the users keep getting the error that dataset is not refreshed. On checking, I saw the following error. 


{"error":{"code":"DMTS_OAuthTokenRefreshFailedError","pbi.error":{"code":"DMTS_OAuthTokenRefreshFailedError","parameters":{"ConnectionDetails":"{\"kind\":\"UsageMetricsDataConnector\",\"path\":\"UsageMetricsDataConnector\"}","CredentialType":"OAuth2","DatasourceType":"Extension"},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"AADSTS700082: The refresh token has expired due to inactivity. The token was issued on 2021-08-25T22:07:49.0848082Z and was inactive for 90.00:00:00

 

I tried refreshing the dataset after updating the credentials and it has not resolved the issue. Any thoughts on why this is occuring and how to refresh the usage metrics in only this specific workspace? 

 

Thanks much! 

2 REPLIES 2
v-henryk-mstf
Community Support
Community Support

Hi @caritesh ,

 

For troubleshooting, you may click “Admin Portal”-> "Tenant Settings"-> "Audit and usage settings", then disable "Usage metrics for content creators" and then enable it again. In addition,  if you are not the current dataset owner, you must take over ownership before you can update the data source credentials.

vhenrykmstf_0-1642126997639.png

Or you can delete the existing Usage Metrics report dataset and re-run View Usage Metrics to generate the new dataset and its associated Improved Usage Metrics report.


If the problem is still not resolved, please provide detailed error information and let me know immediately. Looking forward to your feedback.


Best Regards,
Henry


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello @v-henryk-mstf , 

 

I did take over the dataset and also tried updating the credentials, but we still see the same error and the dataset never refreshed. I did have an admin user also perform the same update and it did not work as well. 

 

Are you recommending that we disable the feature, apply it to the tenant and then renable and apply? We want to try the delete options but are hesistant to go ahead as we do not want to impact other workspaces. Is there an option to just delete the dataset attached the specifc workspace? 

 

Thanks, 

 

Ritesh Menon

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!

Top Solution Authors
Top Kudoed Authors